ЭмилиСтоун11
02.08.2022 18:28

PASCAL Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные
Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр. Числа разделяются пробелами.

Пример:
Ввод Ожидаемый
1. 10 20
2. 1939 3838
Ожидается:
1. 11 12 15
2. 1944 1962 2112 2122 2124 2128 2136 2144 2166 2184 2196 2212 2222 2224 2226 2232 2244 2248 2262 2288 2316 2322 2328 2364 2412 2424 2436 2444 2448 2488 2616 2622 2664 2688 2744 2772 2824 2832 2848 2888 2916 3111 3126 3132 3135 3144 3162 3168 3171 3195 3216 3222 3264 3276 3288 3312 3315 3324 3333 3336 3339 3366 3384 3393 3432 3444 3492 3555 3612 3624 3636 3648 3666 3717 3816

Не копируйте другой ответ с этого же сайта, он не верный

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
777495
23.02.2021 21:50
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var n:=ReadInteger('n=');
  if n<0 then Writeln(n,'! не определено: n<0')
  else
    if n=0 then Writeln('0!=1')
    else begin
      var p:BigInteger:=1;
      for var i:=2 to n do p*=i;
      Writeln(n,'!=',p)
      end
end.

Тестовое решение:
n= 138
138!=691778647261948849222819828311491035886734385827028118707676848307166514238979223884785249055995983385450621636277440066920043595627074569065446040152660143904127838730788278294186615891819670506731208704000000000000000000000000000000000
0,0(0 оценок)
Ответ:
verarusu02
06.05.2023 07:22
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var a:array[1..20] of integer;
  Randomize;
  for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println;
  var b:=Range(2,20,2).Select(i->a[i]);
  Writeln('Элементы с четными индексами по возрастанию');
  b.Sorted.Println;
  Writeln('Элементы с четными индексами по убыванию');
  b.SortedDescending.Println;
end.

Тестовое решение:
-15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40
Элементы с четными индексами по возрастанию
-40 -28 -12 -11 -3 9 12 16 33 46
Элементы с четными индексами по убыванию
46 33 16 12 9 -3 -11 -12 -28 -40
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота