Хаченок1337
17.08.2020 03:19

1. написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tamilazhakupova
20.06.2020 05:56
Я так понимаю, что "значение массива" - это сумма его элементов. Если это так, то вот решение:

1)
Var a,b:array[1..10] of real;
s,k:real; i:integer;
Begin
 wtiteln('Init A:')
 for i:=1 to 10 do
   begin
    readln(k);
    a[i]=k;
   end;
 wtiteln('Init B:')
 for i:=1 to 10 do
   begin
    readln(k);
    b[i]=k;
   end;
 s:=0;
 k:=0;
 for i:=1 to 10 do
   k:=k+a[i];
 k:=k/10;
 for i:= to 10 do
   s:=s+b[i];
 s:=(s/10)+k;
 writeln(s);
End.

2)
Var a,b:array[1..10] of real;
r,k:real, i:integer;
Begin
 writeln('Init A:");
 for i:=1 to 10 do
   begin
    readln(k);
    a[i]:=k;
   end;
 writeln('Init B:");
 for i:=1 to 10 do
   begin
    readln(k);
    b[i]:=k;
   end;
 r:=0
 k:=0;
 for i:=1 to 10 do
   k:=k+a[i];
 for i:=1 to 10 do
   r:=r+b[i];
 r:=r-k;
 writeln(r);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота