nasowmza
11.01.2020 23:23

Задача 5. Составьте программу для вычисления функций у=2х2+5, где х=100,90,80,70,60,50,40,30,20,10

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Milena200516
07.09.2021 16:21
Aurora 3D Text and Logo Maker - это продвинутый, мощный дизайнерский инструмент для создания уникального 3D текста, кнопок и логотипов, имеет достаточно большое количество шаблонов и готовых форм, которые можно использовать для создания собственного текста. Aurora 3D Text and Logo Maker имеет комплект эффектов, анимаций, текстур, с которых можно украсить 3D логотип или текст. При создании трёхмерного логотипа можно отрегулировать уровень света, добавить теней, рельеф, выбирать различные варианты искривления, выравнивания, освещения, наложения объектов и т. д. Допускается импорт шрифтов и SVG-графики. Итоговый вариант выводится в виде PNG, TGA, TIFF, JPG, BMP, XPM и PPM-файлов.
0,0(0 оценок)
Ответ:
Nasta11111112356
10.04.2021 10:54

Задания 4 и 5:

Задание 4:

static void Main(string[] args)

       {

           int N = 10, count, sum = 0;

           int[] mas = new int[N];

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               mas[i] = rnd.Next(0, 10);

           }

           Console.WriteLine("Массив: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,4}", mas[i]));

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.Write("Введите количество элементов для суммирования (n): ");

           count = Convert.ToInt32(Console.ReadLine());

           if (count > N)

           {

               count = N;

               Console.WriteLine();

               Console.Write("Количество элементов не должно превышать размерность массива.");

           }

           for (int i = 0; i < count; i++)

           {

               sum += mas[i];

           }

           Console.WriteLine();

           Console.Write("Сумма первых " + count + " элементов массива = " + sum);

           Console.ReadKey();

       }

Задание 5:

static void Main(string[] args)

       {

           int N = 10, x, y, sum = 0;

           int[] mas = new int[N];

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               mas[i] = rnd.Next(0, 10);

           }

           Console.WriteLine("Массив: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,4}", mas[i]));

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.Write("Введите x: ");

           x = Convert.ToInt32(Console.ReadLine());

           Console.Write("Введите y: ");

           y = Convert.ToInt32(Console.ReadLine());

           if (x > N)

           {

               x = N / 2;

           }

           if (y > N)

           {

               y = N;

           }

           if (y < x)

           {

               x = N / 2;

               y = N;

               Console.WriteLine();

               Console.Write("x не должен быть больше y.");

           }

           for (int i = x - 1; i < y; i++)

           {

               sum += mas[i];

           }

           Console.WriteLine();

           Console.Write("Сумма элементов массива, с " + x + " элемента по " + y + " равна " + sum);

           Console.ReadKey();

       }

Объяснение:

Задания 4 и 5 на языке C#.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота