avisuale
22.01.2023 05:43

6 32-33. Практикум. Программирование алгоритма Уровень А
Программирование линейных алгоритмов.
1. Напишите программу
вычисления длины окружности
и площади круга по величине радиуса круга.
2. Напишите программу вычисления следующих выражений:
Na + +
а) k =
Na2 + b?
2 : у
б) х =
23 +уз​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
klybnika228
31.08.2021 11:27
Program p1;

var
  a, b, c, s: real;

begin
  Writeln('Вычислите S поверхности параллелепипеда.');
  Writeln('Введите исходные данные:');
  Write('Длина(см)? '); Readln(a);
  Write('Ширина(см)? '); Readln(b);
  Write('Высота(см)? '); Readln(c);
  s := 2 * (a * b + b * c + c * a);
  Writeln('Площадь поверхности: ', s, ' кв.см.')
end.

Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.

program p2;
var
  ct,ck,s:real;
  kt,kk:integer;
begin
  Writeln('Вычисление стоимости покупки');
  Writeln('Введите исходные данные:');
  Write('Цена тетради(руб.)? '); Readln(ct);
  Write('Количество тетрадей? '); Readln(kt);
  Write('Цена карандашей(руб.)? '); Readln(ck);
  Write('Количество карандашей? '); Readln(kk);
  s:=ct*kt+ck*kk;
  Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.

Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
0,0(0 оценок)
Ответ:
LRM999919
31.08.2021 11:27
Program p1;

var
  a, b, c, s: real;

begin
  Writeln('Вычислите S поверхности параллелепипеда.');
  Writeln('Введите исходные данные:');
  Write('Длина(см)? '); Readln(a);
  Write('Ширина(см)? '); Readln(b);
  Write('Высота(см)? '); Readln(c);
  s := 2 * (a * b + b * c + c * a);
  Writeln('Площадь поверхности: ', s, ' кв.см.')
end.

Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.

program p2;
var
  ct,ck,s:real;
  kt,kk:integer;
begin
  Writeln('Вычисление стоимости покупки');
  Writeln('Введите исходные данные:');
  Write('Цена тетради(руб.)? '); Readln(ct);
  Write('Количество тетрадей? '); Readln(kt);
  Write('Цена карандашей(руб.)? '); Readln(ck);
  Write('Количество карандашей? '); Readln(kk);
  s:=ct*kt+ck*kk;
  Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.

Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота