антонl
19.10.2020 17:31

Python 1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числами в диапазоне [0,20], выводит его на экран, а затем меняет местами пары соседних элементов, кроме первого и последнего (2-й с 3-м, 4-й с 5-м и т.д.).
Пример:
Массив: 5 16 2 13 3 14 18 17
Реверс: 5 2 16 3 13 18 14 17

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЮляLoveYou
14.01.2023 14:58

program calklin;

uses

 crt;

var

 a, b, x: real;

begin

 textcolor(red);

 gotoxy(10, 5);

 write('Вас приветствует калькулятор решать линейные уравнения');

 gotoxy(10, 6);

 write('Введите а=');

 readln(a);

 gotoxy(10, 7);

 write('Введите b=');

 readln(b);

 gotoxy(10, 8);

 if a = 0

 then

 begin

   gotoxy(10, 9);

   textcolor(red);

   writeln('Нет корней')

 end

 else

 begin

   if a <> 0

   then

   begin

     gotoxy(10, 10);

     textcolor(red);

     x := (-b / a);

     writeln('Уравнение имеет корень и он равен: x =', x, '');

   end;

 end;

end.

0,0(0 оценок)
Ответ:
malaxov04
14.01.2023 14:58

package testStudentCode;

//import java.util.Arrays;

import java.util.Scanner;

public class TestStudentCode {

public static void main(String[] args) {

/* This reads the input provided by user

        * using keyboard

        */

       Scanner scan = new Scanner(System.in);

       System.out.print("a = ?");

       // This method reads the number provided using keyboard

       double a = scan.nextDouble();

       System.out.print("b = ?");

       double b = scan.nextDouble();

       // Closing Scanner after the use

       scan.close();

       System.out.println(a + "x + (" + b + ") = 0");  

       if (a == 0) {

        System.out.println("a = 0");

       } else {

           double x = - b / a;

        System.out.println("x = " + x);

       }

}

}

Объяснение:

как то так

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота