DAYDEMON
06.01.2020 04:24

Напишите программу для вычисления степени k (целое) числа а (действительное). Для этого создайте функцию ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ionutamaria90
06.11.2022 16:00
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrReal('Введите 4 числа:',4);
  if Frac(a.Sum/(a[3]-a[2]))=0 then Writeln('Целый результат')
  else Writeln('Нецелый результат')
end.

Примеры
Введите 4 числа: 7.2 1.8 25.5 5.5
Целый результат

Введите 4 числа: 36 18.6 12 5
Нецелый результат

Объяснения:
Первый (после begin) оператор объявляет массив из четырех вещественных элементов и заполняет его вводимыми с клавиатуры данными.
Второй делает остальное: вычисляет результат, проверяет, целочисленный ли он и выводит соответствующее сообщение на монитор.

50 решите с объяснением проверьте является ли частное от деления суммы четырех произвольных чисел, в
0,0(0 оценок)
Ответ:
Marka9696
24.08.2021 21:27
1. Подготовка к уроку. Линейный алгоритм. Зашел в класс, достал сумку, достал тетрадь, достал ручку, начал писать.
2. Поход в магазин. Разветвляющийся алгоритм. Зашел в магазин, подошел к прилавку, Есть ли молоко. Если "да", то взял молоко, отдал деньги на кассе, вышел из магазина. Если "НЕТ" то сразу вышел из магазина.
3. Циклический алгоритм. Мытье посуды. Вымыл тарелку. Посмотрел есть еще тарелка? Если "ДА", то алгоритм повторяешь снова. Помыл-посмотрел, помыл-посмотрел. Если "НЕТ" (то есть тарелок больше не осталось) то заканчиваешь алгоритм, выключаешь воду, идешь рубиться в C.S.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота