Войти
Регистрация
Спроси ai-bota
Elnur19982
27.04.2021 17:01
1. Напишите программу формирувания и вывода масси- ва произвольного размера так, чтобы каждый последую-
щий элемент, начиная с третьего, был равен сумме двух
предыдущих элементов, уменьшенной в два раза. Два
первых элемента задайте с клавиатуры.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
ffinparnisha
04.11.2022 17:17
Запишите программу, определяющая колво гласных букв в введенном слове...
lilarthur
03.12.2022 17:37
Определите шифр кустик=мэефтю, и зашифруйте слово информатика...
innalemesh1
14.07.2021 08:44
Информационное сообщение объёмом 3 кбайт состоит из 6144 символов. сколько символов содержит алфавит, при которого было записано это сообщение?...
HelpFox
02.09.2020 11:27
Нужна по заранее желательно на python! заполните массив натуральными числами в обратном порядке, начиная со значения x, введённого с клавиатуры. выведите значения...
Łųçů
05.04.2022 08:19
Складіть програму яка визначає менше з двох довільних дійсних чисел....
Overlight1337
16.02.2023 03:54
Введите с клавиатуры текущий год и год рождения. вычислите возраст, если он меньше 18 вывести год совершеннолетия, а если больше, то год выхода на пенсию. вывести...
Юлья0000000
14.07.2020 12:31
Как решить восмеричную систему счисления? Десятичную? двоичную? Шестнадцатеричную? Обьясните кратко...
милка578
14.02.2023 03:21
Определите адрес сети и номер компьютера. 1.172.16.12.12 2. 255. 255. 255. 252 3. 255. 255. 255. 248...
Нига2ц8
21.02.2021 04:51
Значення щільності розміщення напівпровідників (у нанометрах) для виготовлення мікропроцесорів за сучасними технологіями...
qwertyuiop314
27.05.2021 13:15
подскажите сайты где можно бесплатно и много накрутить подписчиков и лайков для Инсты...
Ответ:
milkiweika123
29.12.2020 08:12
#include <stdio.h>
#include <math.h>
int main()
{
float x, y1, y2, y3;
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1<y2)&&(y1<y3)) {
if (y2<y3) printf("%f %f %f", y1,y2,y3);
else printf("%f %f %f", y1,y3,y2);
}
else if ((y2<y1)&&(y2<y3)) {
if (y1<y3) printf("%f %f %f", y2,y1,y3);
else printf("%f %f %f", y2,y3,y1);
}
else if (y1<y2) printf("%f %f %f", y3,y1,y2);
else printf("%f %f %f", y3,y2,y1);
return 0;
}
Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000
0,0
(0 оценок)
Ответ:
SDimassYT
29.12.2020 08:12
#include <stdio.h>
#include <math.h>
int main()
{
float x, y1, y2, y3;
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1<y2)&&(y1<y3)) {
if (y2<y3) printf("%f %f %f", y1,y2,y3);
else printf("%f %f %f", y1,y3,y2);
}
else if ((y2<y1)&&(y2<y3)) {
if (y1<y3) printf("%f %f %f", y2,y1,y3);
else printf("%f %f %f", y2,y3,y1);
}
else if (y1<y2) printf("%f %f %f", y3,y1,y2);
else printf("%f %f %f", y3,y2,y1);
return 0;
}
Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота