yanaqwe
17.01.2021 04:17

Написать программу на питоне, используя цикл while; Условие задачи. Задано число a (1<a<1.5). Из чисел 1+1/2, 1+1/3, 1+1/4 …, напечатать те, которые не меньше a.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elenavalkova92
21.04.2021 11:58

1.

program z1;

const n=5;

var a:array [1..n,1..n] of integer;

i,j,s:integer;

begin

writeln ('Квадратная матрица:');

for i:= 1 to n do

begin

for j:=1 to n do

begin

a[i,j]:=Random(10);

write(a[i,j]:3);

if i=j then s:=s+a[i,j]

end;

writeln;

end;

writeln('Среднее арифметическое элементов расположенных на главной диагонали: ',s/n)

end.

2.

program z2;

const n=5;

var a:array [1..n,1..n] of integer;

i,j,s,sp:integer;

begin

writeln ('Квадратная матрица:');

for i:= 1 to n do

begin

for j:=1 to n do

begin

a[i,j]:=Random(21)-10;

write(a[i,j]:5);

if i=j then s:=s+a[i,j]

end;

writeln;

end;

for i:= 1 to n do

for j:=1 to n do

if (a[i,j]>0) and (a[i,j]>s/n)then sp:=sp+a[i,j];

writeln('Сумма положительных элементов, превышаюших по величине среднее арифметическое всех элементов расположенных на главной диагонали: ',sp)

end.

3.

program z3;

const n=5;

var a:array [1..n,1..n] of integer;

i,j,m,k:integer;

begin

writeln ('Двумерный массив:');

for i:= 1 to n do

begin

for j:=1 to n do

begin

a[i,j]:=Random(21)-10;

write(a[i,j]:5)

end;

writeln;

end;

m:=a[1,1];

for i:= 1 to n do

for j:=1 to n do

if a[i,j]<m then m:=a[i,j];

writeln ('Минимальный элемент ',m);

k:=0;

for i:= 1 to n do

for j:=1 to n do

if a[i,j]=m then

begin

writeln('Индексы [',i,',',j,']');

k:=k+1;

end;

writeln ('Количество минимальных элементов ',k)

end.

0,0(0 оценок)
Ответ:
ktoto215
18.03.2021 08:31

Чтобы понять, что такое файл, давайте рассмотрим простой пример. Каждый из нас хотя бы один раз в жизни бывал на вокзале в камере хранения.

- Как выглядит камера хранения? (В ней стоят стеллажи с ячейками, каждая ячейка имеет строго свой номер, в которой можно оставлять вещи на хранение. Работник камеры хранения регистрирует в журнале данные пассажира и номер ячейки, которую он занял).

- В компьютере материальными носителями являются, магнитные диски, лазерные и т.д. Для того чтобы на диске можно было хранить файлы, диск должен быть предварительно отформатирован. В процессе форматирования на диске выделяются концентрические дорожки, которые в свою очередь, делятся на секторы. Каждой дорожке и каждому сектору присваивается свой порядковый номер.

- Данные подобно вещам в камере хранения распределяются по свободным областям носителя. Можно сказать, что файл - это совокупность данных, хранящихся на внешнем носителе.

- Файл - это определенное количество информации (программа или данные), имеющее имя и хранящееся в долговременной (внешней) памяти.

Объяснение:

вот поставь лайк и оценки

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота