tflash191
07.08.2022 20:39

С использованием функции заполнить массив, каждый элемент которого будет членом последовательности (n-1) / (n + 1) ^ 2 где n-натуральное число, число элементов в массиве равно в водной n Для ввода использовать TEdit

Вывод массива из TMemo

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pidgenatar
21.04.2020 13:21

При определении значений подобных функций переменная y вычисляется по-разному (по разным формулам) в зависимости от значения x.

Такие задачи решаются с конструкции условного оператора if - else. Поскольку в данном случае мы имеем три условия (x > 0, x = 0 и x < 0), то потребуется использование еще вложенной конструкции if - else, т. к. в языке Pascal нет оператора множественного ветвления (оператор case в данном случае не подходит).

В языке программирования Паскаль (да и в других тоже) желательно вложенные конструкции if - else помещать во внешнюю ветку else, а не if. Так проще не запутаться.

Таким образом, алгоритм вычисления значения функции может быть таким:

Если x > 0, то у = x - 2

Иначе (ниже идет вложенная конструкция)

Если x = 0, то y = 0

Иначе y = |x|.

В последнем пункте можно опустить оператор if с проверкой, что x < 0, так как если ход выполнения программы дошел до этого пункта, то x уже другим быть и не может (варианты, когда он больше или равен нулю, уже были исключены).

Для определения модуля (абсолютного значения) переменной можно использовать встроенную функцию abs() языка Pascal. В данном случае можно обойтись и без нее: поскольку уже известно, что x отрицателен, то, чтобы получить положительное число (модуль), нужно его умножить на -1.

var

   x, y: integer;

 

begin

   write ('x = ');

   readln (x);

 

   if x > 0 then

       y := x - 2

   else

       if x = 0 then

           y := 0

       else

           y := abs(x);

 

   writeln ('y = ', y);

 

end.

Объяснение:

0,0(0 оценок)
Ответ:
Tumanovaad12
21.04.2020 13:21

7гтештм8штш7нтш7тшнтг7тгтпш7тштш7тш8тш8шьщьь88ь7о7о7о7о7ьшьщь7ьштиам5п 3 в в в и в в кнк5 пеенрггр ниеиеин синие ини нтгьшб лишь лишь шььш ешь ешь ешь ешь ешь ешь ешь шьЭкономика СССР была административно-командной на протяжении всей его истории. В отдельные периоды (1921-1930, 1987-1991) она "разбавлялась" элементами капиталистической экономики, позволяя частным предпринимателям торговать результатами своего труда по рыночным ценам, однако в целом не меняла своей сути. Лишь в 1990 году была законодательно разрешена частная собственность на средства производства и начался обвальный переход к рыночной экономике западного типа. Однако такой важнейший элемент административно-командной системы, как регулирование цен в государственных магазинах, просуществовал до самого распада СССР.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота