Kanmoen014
05.01.2023 07:01

Уровень A. Напишите программу, которая находит все минимумы и максимумы функции (см. варианты на следующей странице) на интервале [-5;5] с точностью 0,001, используя метод «золотого сечения». Границы интервала для поиска каждого минимума и максимума задаются вручную. Уровень B. Напишите программу, которая находит все минимумы и максимумы функции (см. варианты на следующей странице) на интервале [-5;5] с точностью 0,001, используя метод «золотого сечения». Границы интервала для поиска каждого минимума и максимума определяются автоматически.
Уровень C. Напишите программу, которая находит все минимумы и максимумы функции (см. варианты на следующей странице) на интервале [-5;5] с точностью 0,001, используя метод «золотого сечения», причём на каждом шаге цикла вычисляется только одно новое значение функции. Границы интервала для поиска каждого минимума и максимума определяются автоматически.
Функция: x^3+3x^2-9x-5+cosx

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
rada201
06.05.2023 14:21

2)Pascal

var s: string;

i, f, g: integer;

begin

writeln('Введите строку с угловыми скобками:');

readln(s);

f := pos('<', s);

if f = 0

then begin

write('Нет "<"');

if pos('>', s) = 0

then writeln('и ">"')

else writeln

end

else begin

g := 0;

for i := length(s) downto 1 do

if s[i] = '>'

then begin

g := i;

break

end;

if g = 0

then writeln('Нет ">"')

else if f > g

then writeln('">" левее "<"')

else begin

delete(s, f, g - f + 1);

writeln('Результат:');

writeln(s)

end

end

end.

Если гарантированно, что в тексте есть только по одному правильно расположенному символу "<" и ">", то совсем просто:

Pascal

var s: string;

begin

writeln('Введите строку с угловыми скобками:');

readln(s);

delete(s, pos('<', s), pos('>', s) - pos('<', s) + 1);

writeln('Результат:');

writeln(s)

end.

0

0,0(0 оценок)
Ответ:
Лина1990
10.04.2023 00:43

1)

program fantscrin;

var s:string; i, plus, minus:integer;

begin

   write('Введите строку:'); readln(s);

   plus:= 0;

   minus:= 0;

   for i:=1 to length(s) do

   begin

       if s[i] = '+' then plus := plus + 1;

       if s[i] = '-' then minus := minus + 1;

   end;

   writeln;

   if plus > minus then for i:=1 to plus do

                           write('+')

                   else if plus < minus then for i:=1 to minus do

                                               write('-')

                                        else write('Кол-во знаков одинаковое!');

end.

2)

program fantscrin;

var y,x,b,e:real; i:integer;

begin

   write('Введите число b:'); readln(b);

   e:= 2.7;

   x:= 0;

   writeln;

   writeln('   y    |   x   ');

   writeln('');

   while x <= 10 do

   begin

       if x < 3 then

                begin

                    y:= Exp(x * Ln(e)) + 1 / (x + 1);

                    writeln(y:6:5, ' | ', x:6:5)

                end;

       if x = 3 then

                begin

                    y:= Sin(x) + sqrt(x);

                    writeln(y:6:5, ' | ', x:6:5);

                end;

       if x > 3 then

                begin

                    y:= Cos(x) + Abs(b);

                    writeln(y:6:5, ' | ', x:6:5);

                end;

       x:= x + 0.5;

   end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота