djdhd1
18.04.2020 07:01

, напишите программу, в котором можно узнать сколько ты везишь на разных планетах солнечной системы, на языке С++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lluukkaa
29.11.2020 20:37
1. С=2*Pi*R, S= Pi*R^2, V=4/3*Pi*R^3, где Pi=3,14, заданный радиус R
2. P=a+b, S=1/2*a*b, где a и b - данные катеты
3. Пусть даны координаты трех вершин треугольника A(x1;y1), B(x2;y2), C(x3;y3).
Расстояние между двумя точками вычисляется по формуле
d= \sqrt{ ( x_{2} - x_{1} )^{2}+ ( y_{2} - y_{1} )^{2} }
Тогда периметр треугольника можно вычислить по формуле:
P=sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2).
Площадь треугольника по формуле Герона вычисляется по формуле:
s= \sqrt{p(p-a)(p-b)(p-c)}, где p= \frac{a+b+c}{2}-полу периметр треугольника.
S=sqrt((sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x2-x1)^2+(y2-y1)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-+sqrt((x3-x2)^2+(y3-y2)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x3-x1)^2+(y3-y1)^2))
4. Среднее геометрическое трех чисел вычисляется по формуле
\sqrt[3]{abc} или
(a*b*c)^1/3
0,0(0 оценок)
Ответ:
Bel4onokk
07.03.2023 18:02
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=10;

 Var
 ar:array[1..n] of integer;
 k,i,c:integer;
begin
 randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(9);
   write(ar[i]:4);
  end;
 writeln;
 write('Enter index:');
readln(k);
 if (k=1) or (n=1) then
   begin
   writeln('Mwahahahaha(no)');
   exit;
  end;
 c:=ar[k+1];
 ar[k+1]:=ar[k-1];
 ar[k-1]:=c;
 writeln('Final array:');
 for i:=1 to n do
  write(ar[i]:4);
end.

Пример работы программы:
First array:
   1   8   4   2   8   5   8   7   1   8
Enter index:3
Final array:
   1   2   4   8   8   5   8   7   1   8
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота