Pashayka
04.09.2021 16:12

1. Написать программу на языке Паскаль. Даны катеты прямоугольного треугольника a и b и гипотенуза с. Найти его периметр P: P = a + b + c. 2. Написать программу на языке Паскаль. Условие: если значение переменной х

3. Написать программу на языке Паскаль. Условие: если ученик за тестирование получил то вывести сообщение «зачет сдан», иначе сообщение «зачет не сдан». Данные для ввода: , полученный учеником.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
CRaBFeed
07.08.2021 19:39
PascalABC.NET
Версия 3.3. сборка 1583 (25.11.2017)

var 
 n:integer;
 a:array[1..100] of integer;
begin
 write('Введите размер массива (n<100): ');readln(n);
 var max:=0;
 var min:=101;
 for var i:=1 to n do
 begin
  a[i]:=random(0,100);
  write(a[i],' ');
  if i mod 2=0 then
   if a[i]>max then max:=a[i]
   else
    if a[i]<min then min:=a[i];
 end;
 writeln;
 writeln('Максимальный - ',max);
 writeln('Минимальный - ',min);
 readln;
end.

Пример:

Введите размер массива (n<100): 10
15 32 90 97 35 62 52 37 5 63 
Максимальный - 97
Минимальный - 37
0,0(0 оценок)
Ответ:
ScHooLNick555
07.08.2021 12:19
Пусть первое утверждение первого учителя истинно. Следовательно, можно составить таблицу, где в первой колонке номер учителя, во второй правда/ложь по высказываниям (например, ПЛ означает, что первое высказывание верное, второе ложное, ЛП - наоборот), а во третьем верное высказывание:
1 :: ПЛ :: первое место у Васи
2 :: ПЛ :: второе место у Саши
3 :: ЛП :: четвёртое место у Гриши
4 :: ЛЛ :: противоречие!

Значит, у первого учителя первое высказывание ложное. Составляем таблицу:
1 :: ЛП :: второе место у Юры
2 :: ЛП :: пятое место у Васи
3 :: ЛП :: четвёртое место у Гриши
4 :: ЛЛ :: противоречие!

Мда, у задачи нет решения...
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота