Marina20012608
25.06.2021 04:39

1.Составить программу для вычисления значения суммы чисел кратных 3 в [10,30] 2.А:= ‘КОМПИЛЯТОР’ .Образовать новое слово
«КОМПОТ» /исп COPY/
3.Запишите фрагмент программы:
заполнить массив В(10) :первые 5 эл 2I, другие 3I

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Наташа2511
28.11.2020 02:15

 

Вопрос 1.

Какие ключевые слова не используются для записи команды ветвления?

and  

Вопрос 2.

Как выглядит полная форма команды ветвления?

if ... then ... else ...

  Вопрос 3.

Как выглядит сокращённая форма команды ветвления?

if ... then ...

Вопрос 4.

Какая из команд записана неправильно?

  if a:=0 then a>0;

 

Вопрос 5.

Какая из команд записана правильно?

if x=0 and a>0 then b:=0 else b:=x;

Вопрос 6.

Какая из команд записана правильно?

if (x=0) and (a>0) then begin b:=0;c:=x; end else b:=x;

 

Вопрос 7.

Что будет напечатано на экране в результате выполнения данного фрагмента программы

a:=6;

if a mod 2 = 0 then write(a+2) else write(a-2);

 8  

Вопрос 8.

Что будет напечатано на экране в результате выполнения данного фрагмента программы

a:=12;

if a div 2 >= 6 then b:=a mod 5 else b:=a div 3;

write(a-b);

 10

 

Вопрос 9.

Что будет напечатано на экране в результате выполнения данного фрагмента программы

a:=22;

if a*a >= 225 then a:=a mod 6

Write(22-a);

 18

 

Вопрос 10.

Вставьте пропущенную логическую операцию так, чтобы значение переменной z после выполнения заданного фрагмента программы стало равным 9

a:=5; b:=8; c:=11;

if (a>b) ... (b

 4 не знаю - ФРАГМЕНТ ПРОГРАММЫ НЕ ДОПИСАН

 

Вопрос 11.

Вставьте пропущенную логическую операцию так, чтобы значение переменной z после выполнения заданного фрагмента программы стало равным 3

a:=15; b:=7; c:=4;

if (a>b) ... (b

4 не знаю - ФРАГМЕНТ ПРОГРАММЫ НЕ ДОПИСАН

 

Вопрос 12.

Вставьте пропущенную логическую операцию так, чтобы значение переменной z после выполнения заданного фрагмента программы стало равным 5

a:=1; b:=8; c:=6;

if (a<=c) ... (b<=c) then z:=c-a else z:=c-b;

2 or
0,0(0 оценок)
Ответ:
Herty22436
28.11.2020 02:15

1)      а:=b(13)+a(-2)*3=13+(-2*3)=13-6=7

2)      a) readln(а); readln(х);

б) writeln(z)

в)    var b,c : real; (чаще всего используется при нахождении вещественных чисел)

        var a: integer; (чаще всего используется при нахождении вещественных чисел)

г) if d = a(число, которому нужно прировнять, этот фрагмент цикла(если…,то ..иначе)) then d:=d+20; д) z := x + y; ( : = это знак присвоения)
3) 

PROGRAM PR1;

var w,s,b: integer;

BEGIN

READLN (S, B);

w:= ((12*s) + (26*b));

WRITELN (W);

end.
4) Запишите на языке Паскаль следующие условия:
а) f >105 ;
б)  a<184  ;
в)  w<>181;  
г)  z>0;
д) z<=d;
е) (y*x)>=(d+w);
ж)  (w-d)<88;
з) f>=1;
5. Запишите на языке Паскаль команду ветвления для решения следующей задачи:

а) if  a<> 21 then a:=a+28 else a:=a-51;
б) if  a mod  2=0 then a:=a+5 else a:=a-12;

6. Запишите на языке Паскаль команду цикла для решения следующей задачи:
а)  PROGRAM PR1;
var j,p: integer;
BEGIN j:=1; p:=0;
While j>=66 do BEGIN p:= p*j; j:=j+1:
WRITELN (‘произведение чисел = ‘, p);
end.
б)  

PROGRAM PR1;

var n:integer;

begin

for n:=1 to 7 do

writeln('trud');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота