Полина3061
09.02.2021 20:39

Составить программу в Python,которая проверяет четные и нечетные числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
uchenik0012
07.09.2021 04:33

Название "алгоритм" произошло от латинской формы имени величайшего среднеазиатского математика Мухаммеда ибн Муса ал-Хорезми (Alhorithmi), жившего в 783—850 гг. В своей книге "Об индийском счете" он изложил правила записи натуральных чисел с арабских цифр и правила действий над ними "столбиком", знакомые теперь каждому школьнику. В XII веке эта книга была переведена на латынь и получила широкое рас в Европе.

Человек ежедневно встречается с необходимостью следовать тем или иным правилам, выполнять различные инструкции и указания. Например, переходя через дорогу на перекрестке без светофора надо сначала посмотреть направо. Если машин нет, то перейти полдороги, а если машины есть, ждать, пока они пройдут, затем перейти полдороги. После этого посмотреть налево и, если машин нет, то перейти дорогу до конца, а если машины есть, ждать, пока они пройдут, а затем перейти дорогу до конца.

В математике для решения типовых задач мы используем определенные правила, описывающие последовательности действий. Например, правила сложения дробных чисел, решения квадратных уравнений и т. д. Обычно любые инструкции и правила представляют собой последовательность действий, которые необходимо выполнить в определенном порядке. Для решения задачи надо знать, что дано, что следует получить и какие действия и в каком порядке следует для этого выполнить. Предписание, определяющее порядок выполнения действий над данными с целью получения искомых результатов, и есть алгоритм.

0,0(0 оценок)
Ответ:
nvel1999
17.04.2020 08:47
A,b,c - стороны прямоугольного треугольника;
d - радиус описанной окружности около прям. треуг.
e - длинна окружности описанной около прямоуг. треугольника;

var a,b,c,d,e:Real;
begin
writeln ('Введите (через пробел) 2 катета прямоугольного треугольника: ');
readln (a,b); //вводим 2 катета
c:=SQRT((a*a)+(b*b)); //находим 3 сторону (гипотенузу)
d:=0.5*c; //радиус описанной окружности около прям. треуг
e:=2*3.14*d; //теперь находим длину окружности описанной около прям. треуг.
writeln ('Длина окружности описанной около прямоугольного треугольника = ',e);
end.

P.S. то что после // - это комментарий (в паскале он будет выделен другим цветом), это для того что бы было понятно, что сейчас делаем, если комментарии не нужны - их можно удалить, на правильность работы программы это никак не повлияет
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота