Лина1990
30.06.2020 15:16

Михаил решил написать программу для принадлежности точек заданной области (на рисунке) в декартовой системе координат: Михаил забыл, как правильно ставить условия ему дописать программу (составь условие). С клавиатуры вводятся две координаты точки — x, y (целые числа). Необходимо определить, принадлежит эта точка к заштрихованной области или нет (сначала проверяем наклонную прямую, потом — вертикальную и горизонтальную):

( ) ( ) ( )


Михаил решил написать программу для принадлежности точек заданной области (на рисунке) в декартовой
Михаил решил написать программу для принадлежности точек заданной области (на рисунке) в декартовой

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastya2719
03.08.2021 01:52

1. Сначала посмотри на название статьи, параграфа, брошюры и т. д.
2. Вспомни и запиши все, что ты знаешь или только слышал по этой теме. Можешь записать и свои предположения.
3. Обменяйся информацией с приятелем.
4. Составляется коллективный «банк предложений».
5. Прочитай текст, делая пометки карандашом.

 - уже знал;

 + - новая для меня информация;
 - - думал иначе;
  ? - не понял, есть вопросы.
6. Текст прочитан. Вернитесь к первоначальным записям. Какие подтвердились? Какие предположения оказались ложными? Какие не нашли подтверждения?
7. Чтобы превратить информацию в знания, необходимо проговорить и осмыслить прочитанное.
Этапы стратегии IDEAL
I — Выделите в тексте проблему. Какую главную проблему должны решить герои?
D -- Опишите ее (выявите ее суть).Какой важной информацией снабдил вас автор?
Е - Определите варианты подходов к. решению проблемы. Каковы на ваш взгляд три главных решения проблемы?
А-- Действуйте (решайте). Какой из выбранных вами наилучший?
L — Сделайте вывод, проведите рефлексию своей работы. 
. 

0,0(0 оценок)
Ответ:
PotyLive
15.04.2022 04:23

#include <iostream>

#include <stdlib.h>

using namespace std;

int main()

{

   int arr[10], sum = 0; // Создаём массив и переменную, в которой будет сумма

   for (int i = 0; i < 10; i++) {

       int r = rand() %11 - 5; // Генерация случайного числа в промежутке от [-5; 5]

       arr[i] = r; // Присваем значение перменной

       cout << arr[i] << " "; // Вывод массива.

   }

   cout << endl;

   for (int i = 0; i < 10; i++) {

           if (arr[i] > 0) {  

           sum += arr[i]; // sum = sum + arr[i]

       }

   }

   cout << "Summa polozhitelnih: " << sum << endl;

   return 0;

}

Более оптимальный

#include <iostream>

#include <stdlib.h>

using namespace std;

int main()

{

   int arr[10], sum = 0; // Создаём массив и переменную, в которой будет сумма

   for (int i = 0; i < 10; i++) {

       int r = rand() %11 - 5; // Генерация случайного числа в промежутке от [-5; 5]

       arr[i] = r; // Присваем значение перменной

       cout << arr[i] << " "; // Вывод массива.

       if (i == 9) { cout << endl;}

       if (arr[i] > 0) {  

           sum += arr[i]; // sum = sum + arr[i]

       }

   }

   cout << "Summa polozhitelnih: " << sum << endl;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота