Султи1
19.05.2021 03:58

Напишите программу на питоне по алгоритму ​


Напишите программу на питоне по алгоритму ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Катя388891
16.06.2020 07:41

Решение, что называется, "в лоб" (далеко, очень далеко, не самое лучшее):  

var s,k1,k5,k10,k50,k100,k500,k1000,k10000:integer;  

begin  

write('s = '); readln(s);  

k1:=0; k5:=0; k10:=0; k50:=0;  

k100:=0; k500:=0; k1000:=0; k10000:=0;  

while s>=10000 do begin s:=s-10000; k10000:=k10000+1; end;  

while s>=1000 do begin s:=s-1000; k1000:=k1000+1; end;  

while s>=500 do begin s:=s-500; k500:=k500+1; end;  

while s>=100 do begin s:=s-100; k100:=k100+1; end;  

while s>=50 do begin s:=s-50; k50:=k50+1; end;  

while s>=10 do begin s:=s-10; k10:=k10+1; end;  

while s>=5 do begin s:=s-5; k5:=k5+1; end;  

while s>=1 do begin s:=s-1; k1:=k1+1; end;  

writeln('k10000=',k10000,' k1000=',k1000,' k500=',k500,' k100=',k100,' k50=',k50,' k10=',k10,' k5=',k5,' k1=',k1);  

writeln(' Всего купюр = ',k1+k5+k10+k50+k100+k500+k1000+k10000);  

end.  

Пример:  

s = 27879  

k10000=2 k1000=7 k500=1 k100=3 k50=1 k10=2 k5=1 k1=4  

Всего купюр = 21

0,0(0 оценок)
Ответ:
Fgreep
25.04.2021 11:19

var

Nr , V1 , Va , Na : real;

begin

 Writeln('Сколько рыбок?');

 readln(Nr);

 while(Nr <= 0) do

     begin

       Writeln('Некорректное число');

       Writeln('Сколько рыбок?');

       readln(Nr);

     end;

     

 Writeln('Сколько литров на одну рыбку?');

 readln(V1);

   while(V1 <= 0) do

     begin

       Writeln('Некорректное число');

       Writeln('Сколько литров на одну рыбку?');

       readln(V1);

     end;

     

 Writeln('Требуется воды = ', V1*Nr, ' л');

 Writeln('Сколько аквариумов можно разместить?');

 readln(Na);

   while(Na <= 0) do

     begin

       Writeln('Некорректное число');

       Writeln('Сколько аквариумов можно разместить?');

       readln(Na);

     end;

     

 Writeln('Какой объем у аквариумов?');

 readln(Va);

   while(Va <= 0) do

     begin

       Writeln('Некорректное число');

       Writeln('Какой объем у аквариумов?');

       readln(Va);

     end;

     

 if (V1*Nr <= Va*Na) and (Na <= Nr) then  

   begin

     Writeln('Минимальный объем (в литрах) в аквариуме = ', Va);

   end

 else

   begin

     Writeln('No');

   end;

   

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота