Войти
Регистрация
Спроси ai-bota
olya801
27.02.2020 11:18
нарисовать в pascale abc флаг Науру( мне очень )!
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
likavudu
13.12.2022 11:09
Какие исполнители могут выполнять следующие виды работы? 1. приготовление обеда - 2. уборка квартиры - 3. уборка мусора во дворе - 4. стирка - 5. перевозка пассажиров - 6. обучение...
sofaTV
14.12.2020 15:59
Определите значение переменной c после выполнения следующего фрагмента программы. a := 15; a := a + 6; b := –a; c := -a – 3 * b;...
ФлэшДевушка
30.10.2020 12:58
Информатика python. Программа 1 Составь и запиши программу на языке Python: Если число кратно 7, возвести его в куб, иначе уменьшить данное число на 10. Программа 2 Составь и запиши...
DdMirko
04.03.2022 16:18
Хелп ми дана программа на языке паскаль: program a2; var a, b, с, min: real; begin writeln ( введите три числа ); readln (a, b, с); min : = а; if b if c writeln ( min= ,min) end....
ildarka34
25.12.2020 22:30
Информатика. 7 класс. на фотографии....
gladyshchuk71
22.11.2020 10:21
Напишите алгоритмы, под которых робот, начальное положение которого отмечено *, закрасит отмеченные на рисунках клетки. при разработке алгоритмов используйте цикл с заданным числом...
shilinvanechka
13.01.2020 07:43
Построить блок схему по уравнению используя постусловие repeatm=2шаг=1...
sofisnow0826
03.04.2022 23:33
Составьте программу вычисления в массиве a(n) суммы всех чисел кратных 7 в кумире...
kudar2
13.06.2021 15:45
Вычислите выражения: а) (11111012 + af16)/368; б) 1258 + 111012*a216 - 14178;...
щотььллл
13.06.2020 05:58
Вывести на экран n-раз двухзначное число, вводимое с клавиатуры 15...
Ответ:
rinat0501
01.05.2020 02:37
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!
Самое глупое, что можно было придумать - использовать цикл с предусловием while ... do там, где имеется заданное число повторений:
begin
var n:=ReadInteger('n=');
var (s,i):=(0.0,1);
while i<=n do begin
s+=1/Sqr(2*i+1);
i+=1
end;
Writeln('S=',s)
end.
Пример
n= 10
S=0.210988884817533
Гораздо естественнее тут выглядит цикл со счетчиком:
begin
var n:=ReadInteger('n=');
var s:=0.0;
for var i:=1 to n do
s+=1/Sqr(2*i+1);
Writeln('S=',s)
end.
А если использовать современные возможности программирования в PascalABC.NET, решение вообще в одну строчку:
begin
Writeln('S=',SeqGen(ReadInteger('n='),t->1/Sqr(2*t+1),1).Sum)
end.
0,0
(0 оценок)
Ответ:
healarcimbo
01.05.2020 02:37
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!
Самое глупое, что можно было придумать - использовать цикл с предусловием while ... do там, где имеется заданное число повторений:
begin
var n:=ReadInteger('n=');
var (s,i):=(0.0,1);
while i<=n do begin
s+=1/Sqr(2*i+1);
i+=1
end;
Writeln('S=',s)
end.
Пример
n= 10
S=0.210988884817533
Гораздо естественнее тут выглядит цикл со счетчиком:
begin
var n:=ReadInteger('n=');
var s:=0.0;
for var i:=1 to n do
s+=1/Sqr(2*i+1);
Writeln('S=',s)
end.
А если использовать современные возможности программирования в PascalABC.NET, решение вообще в одну строчку:
begin
Writeln('S=',SeqGen(ReadInteger('n='),t->1/Sqr(2*t+1),1).Sum)
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота