Кто разбирается в PYTHON решите задачу Обработка текста
Напишите программу для обработки текста.
На вход вашей программы подаётся многострочный текст, причём число строк заранее неизвестно. Ваша задача – пронумеровать слова в нём, начиная с нуля, а затем вывести только те слова, которые начинаются с большой буквы. Перед словом необходимо вывести номер первого вхождения этого слова в текст.
Слова необходимо отсортировать в лексикографическом порядке.
Формат ввода Несколько строк текста.
Формат вывода Номер первого вхождения этого слова в текст и само слово, разделённые дефисом.
Примечания Для решения этой задачи вам итератор enumerate.
Program yeah; var a,b,c,d,n:integer; begin writeln('введите число.(0-юноша,1-девушка).'); readln(n); if n=0 then begin writeln('введите вес'); readln(a); writeln('введите рост'); readln(b); if b=110 then begin if a<=b then writeln('юноша принят.'); end; if a>b then writeln('не подходит по весу.'); if b<>110 then writeln('не подходит по росту.'); end; if n=1 then begin writeln('введите вес'); readln(a); writeln('введите рост'); readln(b); if b=115 then begin if a<=b then writeln('девушка принята.'); end; if a>b then writeln('не подходит по весу.'); if b<>115 then writeln('не подходит по росту.'); end; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку