Angelochek1915
28.09.2022 08:36

Здраствуйте решить задачу на Python Аве, Цезарь ️
На вход программе подается строка текста на английском языке, в которой нужно зашифровать все слова. Каждое слово строки следует зашифровать с шифра Цезаря (циклического сдвига на длину этого слова). Строчные буквы при этом остаются строчными, а прописные – прописными.

Формат входных данных
На вход программе подается строка текста на английском языке.

Формат выходных данных
Программа должна вывести зашифрованный текст в соответствии с условием задачи.

Примечание. Символы, не являющиеся английскими буквами, не изменяются.

Sample Input 1:

Day, mice. "Year" is a mistake!
Sample Output 1:

Gdb, qmgi. "Ciev" ku b tpzahrl!
Sample Input 2:

my name is Python!
Sample Output 2:

oa reqi ku Veznut!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladimlr
11.06.2022 22:42

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

0,0(0 оценок)
Ответ:
dianabiran
22.09.2020 09:07

#include <stdlib.h>

#include <time.h>

#include <iostream>

using namespace std;

#define N 16

void main()

{

   int randomNumbers[N];

   srand(time(NULL));

   for (int i = 0;i < N; i++)

   {

       randomNumbers[i] = rand() % 40 - 20;

       cout << "randomNumber[" << i << "] = " << randomNumbers[i] << endl;

   }

   cout << endl;

   int counter = 0;

   for (int i = 0; i < N; i++)

   {

       if (randomNumbers[i] < 0)

       {

           counter++;

       }

   }

   cout << "counter = " << counter << endl;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота