Сашок311
17.09.2020 23:47

ОЧЕНЬ .Программирование разветвляющихся алгоритмов. Проверочная работа. Выполните задания.

1 задание.

Что такое разветвляющийся алгоритм?

2 задание.

Напишите общий вид условного оператора.

3 задание.

Напишите вид составного оператора.

4 задание.

Допишите программу в Pascal и определите значения переменной x после выполнения программы. Запишите чему равен x.

a := 2;

x := a+2;

if x > 4 then

x := x+2*a

else x:= a-x;

5 задание.

Допишите программу в Pascal и определите значения переменной Z после выполнения программы. Запишите на листочке чему равен z.

x := 5;

y := 24;

y := y - 2*x;

if (x > y) and (y < 0) then

z := x + y

else z:= x - y;

6 задание.

Напишите программу в Pascal, которая выводит наименьшую из четырех величин a,b,c,d.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Karina902
15.09.2022 08:52
ответ:Ақпарат (лат. informatio — түсіндіру, мазмұндау) ұғымы күнделікті өмірден бастап техникалық салада пайдаланылатын көп мағыналы ұғым. Жалпы алғанда бұл ұғым шектеу, байланыс, бақылау, форма, инструкция, білiм, мағына, құрылым, бейнелеу, сезіну тағы басқа ұғымдармен тығыз байланысты. Көп адам бұл жайлы Білім дәуірі немесе білім қоғамы тудырған Ақпарат дәуірі туралы айта бастады; ақпараттық қоғам, ақпараттық технологиялар, тіпті информатика, ақпарат ғылымы және компьютер ғылымы назарға көп түсуде, ал “ақпарат” сөзі білдіре бастаған мағыналары ұқыпсыз пайдаланылуда.
0,0(0 оценок)
Ответ:
awoln
02.10.2020 12:30
1. Короткий современный вариант ("один оператор")

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  Writeln('Sпол.неч = ',ArrRandom(50,-10,20).Println
    .Where((x,i)->(x>0) and (i.IsEven)).Sum)
end.

Тестовое решение
15 16 0 17 20 7 -3 -4 9 9 -3 -8 14 10 10 11 7 18 -8 8 0 15 1 4 11 1 9 -10 -7 -7 12 17 8 13 7 15 1 13 12 11 4 -5 -3 -6 -5 -10 -9 -8 8 -8
Sпол.неч = 148

2. Длинный "школьный" вариант ("почувствуйте разницу")

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
  a:array[1..50] of integer;
  i,s:integer;
begin
  Randomize;
  s:=0;
  for i:=1 to 50 do begin
    a[i]:=Random(31)-10; Write(a[i],' ');
    if (a[i]>0) and Odd(i) then s:=s+a[i]
    end;
  Writeln;
  Writeln('Sпол.неч = ',s)
end.

Тестовое решение
4 14 4 7 9 -4 3 6 20 -10 3 -3 15 12 9 0 3 12 13 -1 9 -2 -2 16 18 -2 5 9 17 -3 4 -6 10 10 -5 10 8 13 12 15 13 1 12 1 7 6 9 2 -9 -6
Sпол.неч = 207
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота