jsjdnnx
03.03.2023 03:32

Преподаватель по программированию некоего Центра для одаренных детей, узнав, что его ученики знают математику 3-го класса на 97.001 процентов, решил проверить их знания по курсу математики 1-го класса. Для этого он взял за основу популярнейшую у математиков 1-го класса задачу. Первоклассник должен был продолжить следующую последовательность рядов:

1

11

21

1211

111221

312211

13112221

Входные данные
В единственной строке входного файла записаны два целых числа через пробел: x(0<=x<=100) - первый член последовательности и n(1<=n<=25).

Выходные данные
Выведите n-ый ряд x-ой последовательности

Примеры
входные данные
1 4
выходные данные
1211

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lera1059
27.11.2022 04:03
uses crt; var s:string;     c:char;     m:set of char;     n,i,k,p:byte; begin writeln('Введите текст из строчных латинских букв, окончаание ввода Enter'); s:=''; repeat c:=readkey; if c in ['a'..'z'] then  begin   write(c);   s:=s+c;  end; if c=#13 then writeln until c=#13; n:=length(s); m:=[]; for c:='a' to 'z' do  begin   k:=0;   for i:=1 to n do   if s[i]=c then k:=k+1;   if k>1 then m:=m+[c];  end; if m=[] then write('Нет букв, встречающихся более 1 раза') else  for c:='a' to 'z' do  if c in m then write(c) end.
0,0(0 оценок)
Ответ:
Aleksey311
02.12.2020 14:16

1. Во втором письме содержится меньшее количество информации на 5 500 бит

2. 256 секунд

Объяснение:

1.

I = К * i, где

I - информационный объём письма (документа)

К - количество символов в письме (документе)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

N = 2^i, где

N - мощность алфавита (количество символов в алфавите)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

Дано:

K₁ = 25 строк * 50 символов = 1 250 символов

N₁ = 256 символа

K₂ = 2 страницы * 15 строк * 30 символов = 900 символов

N₂ = 32 символа

Найти:

I ₁ - I₂

256 = 2^i ₁

i₁ = 8 бит

32 = 2^i ₂

i₂ = 5 бит

I₁ = 1 250 * 8 = 10 000 бит

I₂ = 900 * 5 = 4 500 бит

I ₁ - I₂ = 10 000 - 4 500 = 5 500 бит

2.

I = К * i, где

I - информационный объём сообщения (документа)

К - количество символов в сообщении (документе)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

К = V * t, где

K - количество символов в сообщении (документе)

V - скорость печати принтера

t - время печати принтера

Дано:

V = 1 024 символа/с

I = 256 Кбайт = 262 144 байт

i = 1 байт (предположительно)

Найти:

t

I = К * i

К = I / i

К = 262 144 / 1 = 262 144 символов

К = V * t

t = К / V

t = 262 144 / 1 024 = 256 секунд

1 Кбайт = 1024 байт

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота