yourname7
18.05.2020 23:03

ОЧЕНЬ ! Напишите программу зеркального отображения элементов одномерного массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
avatar23455
03.10.2020 18:43

ответ

4,0/5

56

author_link

Heicho

умный

56 ответов

3.7 тыс. пользователей, получивших

а) 1 *2^{0}+1 *2^{3} +1* 2^{2}+1* 2^{4}+1* 2^{5}+1* 2^{7} =1+4+8+16+32+128=189 степени расставлять с конца (начиная с нуля)

б) 112 (см. а)

в) деление в один большой столбик. если число четное, то в остатке 0, а если нечетное, то единица. число собирать с конца. 1100011101101

г) 10010100110 (см. в)

д) 10000101101

е) 10011010100 (см.в)

ж) 10101100000011

з) 27 (см. а)

и) 752

а) вверху дописано

г) лучше делить столбиком, как в 1-м классе, но тут неудобно так писать, поэтому я распишу так.

1190/2=595 (ост. 0)

595/2=297 (ост.1)

297/2=148 (ост.1)

148/2=74 (ост. 0)

74/2=37 (ост.0)

37/2=18 (ост. 1)

18/2=9 (ост. 0)

9/2=4 (ост.1)

4/2=2 (ост.0)

2/2=1 (ост.0)

собираем с конца 10010100110

б)

ж)11011/2=5505 (1)

5505/2=2752(1)

2752/2=1376(0)

1376/2=688(0)

688/2=344(0)

344/2=172(0)

172/2=86(0)

86/2=43(0)

43/2=21(1)

21/2=10(1)

10/2=5(0)

5/2=2(1)

2/2=1(0)

10101100000011

з)=27

0,0(0 оценок)
Ответ:
незнакомка1232
07.05.2021 06:57

Программа:

Python:

from random import randint

pts = 100

while pts > 0:

  num, bet = map(int, input('Введите число от 2 до 12 и ставку: ').split())

  if bet > pts:  print(f'У вас не хватает очков! Вы имеете {pts} очков.')

  else:

      cube1, cube2 = randint(1,6), randint(1,6)

      print(f'Первый куб: {cube1}, второй куб: {cube2}')

      summ = cube1 + cube2

      if (summ < 7 and num < 7) or (summ > 7 and num > 7):

          pts += bet

          print(f'Ваша ставка ! Теперь у вас {pts} очков.')

      elif summ == num:

          pts += bet * 4

          print(f'Ваша ставка ! Теперь у вас {pts} очков.')

      else:

          pts -= bet

          print(f'Ваша ставка не ! Теперь у вас {pts} очков.')

      if input('Желаете закончить игру (да/нет)? ').lower() == 'да':

          print(f'Вы закончили игру с {pts} очков.')

          break

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота