va1k
11.04.2023 01:03

Составьте программу вычисления в массиве B(8) суммы нечетных элементов (паскаль 9 класс) ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Helpmepleasewith
29.12.2022 07:15

Отмечено как нарушение через stoker ( W: 0% T: 4 )

Причина: смотри (^ этот символ означает степень, например 3^2 = три в квадрате или три в степени два) :
2,1 ГБайт * 90% = 1,89 ГБайт
1,89 ГБайт = 1,89 * 2^10 МБайт
1,89 ГБайт = 1,89 * 2^20 КБайт
1,89 ГБайт = 1,89 * 2^30 Байт

При сохранении текста обычно используется кодировка ASCII (26+26+33+33+10+спец.символы ~= 256 => 1 символ занимает 8 бит то есть 1 Байт)

Таким образом, из условий задачи мы имеем, что скорость записи составляет 200 символов * 1 Байт = 200 Байт/ минуту

200 Байт представим в виде 100 * 2

Теперь 3 класс S=t*v => t=S/v
Дано:
s=1,89 * 2^30 КБайт
v=100*2^1
t - ?

Решение:
t=(1,89 * 2^30) / (100*2^1) = 0,0189 * 2^29 (минут)

Округлив - получается где-то 19 лет и 4 месяца (19,358 лет)
0,0(0 оценок)
Ответ:
marinatabeleva4
11.05.2023 13:05

var a,b,c,d:real;

Begin

   read(a,b,c,d);

   if ((a<c) and (b<d)) or ((b<c) and (a<d)) then

     writeln('Впишется')

   else writeln('Не впишется');

End.

 

var a,b,c:real;

Begin

   read(a,b,c);

   if (a>b) and (a>c) then a:= b*c;

   if (b>a) and (b>c) then a:= a*c;

   if (c>b) and (c>a) then a:= b*a;

 

   writeln(a);

End.

3)var x,y,z,u:real;
function max(x,y,z:real):real;
begin
  if (x>=y) and (x>=z) then max:= x;
  if (y>=x) and (y>=z) then max:= y;
  if (z>=y) and (z>=x) then max:= z;
end;

function min(x,y,z:real):real;
begin
  if (x<=y) and (x<=z) then min:= x;
  if (y<=x) and (y<=z) then min:= y;
  if (z<=y) and (z<=x) then min:= z;
end;

Begin
    read(x,y,z);
    u:=(max(x,y,z)*max(x,y,z)-exp(x*ln(2)))/(sin(2*x)+max(x,y,z)/min(x,y,z));
    writeln(u);
End.

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота