dilya69202
07.03.2023 19:45

Составьте программу с использованием графических примитивов (не менее трех) Помните: сначала нужно подготовить эскиз рисунка на листе в клетку!

import pygame
from math import pi
pygame.init()
#определение цветов в формате RGB
BLACK = ( 0, 0, 0)
WHITE = (255, 255, 255)
BLUE = ( 0, 0, 255)
GREEN = ( 0, 255, 0)
RED = (255, 0, 0)
#обозначение высоты и ширины экрана
size = [400, 300]
screen = pygame.display.set_mode(size)
#обозначение названия окна
pygame.display.set_caption("Пример рисования")
#Очистка экрана и установка белого фона экрана
screen.fill(WHITE)
#Нарисуем на экране черную линию от точки (0,0)до (40,40) шириной в 4 пикселя
pygame.draw.line(screen, BLACK, [0, 0], [40,40], 4)
#Нарисуем на экране несколько смежных отрезков шириной в 4 пикселя
pygame.draw.lines(screen, GREEN, False, [[60,20], [100, 20], [140, 5],
[180, 20], [220,20]], 4)
#Нарисуем на экране сплошную линию от точки (0,50)до (40,90) шириной в 2 пикселя
pygame.draw.aaline(screen, BLACK, [0, 50],[40,90], 2)
#Нарисуем прямоугольник, начиная с точки (60,60),с длиной и шириной сторон в 60 пикселей, толщиной
#линии в 1 пиксель
pygame.draw.rect(screen, BLUE, [60,60,60,60], 1)
#Нарисуем сплошной залитый прямоугольник, начиная
#с точки (140,60), с длиной и шириной сторон в 60 пикселей
pygame.draw.rect(screen, BLUE, [140, 60,60,60])
#Нарисуем окружность с центром в точке (90,170)
#и радиуса 30 пикселей
pygame.draw.circle(screen, BLACK, [90, 170], 30,1)
#Нарисуем сплошной залитый круг с центром в точке
#(170,170) и радиуса 30 пикселей
pygame.draw.circle(screen, BLACK, [170, 170], 30)
#Нарисуем эллипс, используя прямоугольник
pygame.draw.ellipse(screen,RED,[60,220,60,30],1)
#Нарисуем сплошной залитый эллипс, используя прямоугольник
pygame.draw.ellipse(screen, RED, [140,220,60,30])
#Нарисуем треугольник с функции рисования многоугольника

pygame.draw.polygon(screen, BLACK, [[170, 25],
[140, 60], [200, 60]], 5)
#Нарисуем дугу эллипса, используя радианную меру угла
pygame.draw.arc(screen, RED,[210, 75, 150, 125],0, pi/2, 3)
pygame.draw.arc(screen, GREEN,[210, 75, 150,125], pi/2, pi, 3)
pygame.draw.arc(screen, BLUE, [210, 75, 150, 125],pi,3*pi/2, 3)
pygame.draw.arc(screen, BLACK, [210, 75, 150,125], 3*pi/2, 2*pi, 3)
#Обновим экран после использования функций рисований
pygame.display.flip()
#обработка событий

while True:
for event in pygame.event.get():
if event.type == pygame.QUIT:
exit()

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MigelAlemanValdes
30.08.2021 13:41
Program Project1;

var m:array [0..14] of integer; i:integer;

function IsPositive(a:integer):boolean;
begin
  result:=(a>-1);
end;

procedure work;
var min, max, count:integer;
begin
  count:=0;
  min:=m[0];
  max:=0;
  for i:=0 to 14 do begin
    if IsPositive(m[i]) then begin
      inc(count);
      if m[i]>max then max:=m[i];
      if m[i]<min then min:=m[i];
    end;
  end;
  writeln('MAX: ', max);
  writeln('MIN: ', min);
  writeln('Count: ', count);
end;

begin
  for i:=0 to 14 do begin
    write('n: ');
    readln(m[i]);
  end;

  work;

  readln;
end.
0,0(0 оценок)
Ответ:
AnnaNazar07
23.05.2023 01:56
Таких систем исчисления всего две.  Основание а = 9 и основание а =367, но в системе с основанием 367 проблематично записывать числа (символов не хватит).
Если число 3306(10) в системе исчисления с основанием а заканчивается цифрой 3, то тогда
число 3303 делится на основание системы а.
Отсюда алгоритм поиска.  Находим все делители числа 3303.
3303 = 3*1101 = 3*3*367.  Число 367 - простое. Поэтому основаниями системы исчисления 
могут быть только 3, 9, 367.  Основание =3 не подходит, так как по условию число должно заканчиваться на 3  -> основание больше 3.  Остаются 9, 367.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота