Fromsay
31.10.2020 11:44

составьте программу объема пирамиды v=1/3 tir^2 h​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
FOXyashka2005
12.09.2021 21:42
Функция x mod 10 - это остаток от деления х на 10. 387 mod 10 = 7.
Функция x div 10 - это целочисленное деление x на 10. 387 div 10 = 38.
L увеличивается в цикле каждый раз на 1. Значит, было 3 цикла.
х каждый раз целочисленно делится на 10.
Цикл идет, пока x > 5. Значит, последний раз было x < 50.
M - это наименьший остаток от деления x на 10.
Если на выходе M  = 4, значит остатки были: 9, 8, 7, 6, 5, 4.
Допустим, остатки были 9, 9, и 4, и последний раз было x = 49,
тогда на 2-ом цикле было x = 499, а на 1-ом x = 4994.
Проверяем:
1 цикл. M = 9, x = 4994, x mod 10 = 4994 mod 10 = 4
9 > 4 ? Да, значит M = 4. x = x div 10 = 4994 div 10 = 499
2 цикл. M = 4, x = 499, x mod 10 = 499 mod 10 = 9
4 > 9 ? Нет, значит М остается = 4. x div 10 = 499 div 10 = 49.
3 цикл. M = 4, x = 49, x mod 10 = 49 mod 10 = 9.
4 > 9 ? Нет, значит М остается = 4. x div 10 = 49 div 10 = 4
Условие цикла x > 5 не выполняется, выходим из цикла.
0,0(0 оценок)
Ответ:
oborinamascha
14.12.2021 19:58
//Как давно я не писал program
//Pascal ABC.NET v3.1 сборка 1219

program boshe10iz10;
Var
 xa,ya,xb,yb:real;

 function qua(x,y:real):byte;
 begin
  if (x>0) and (y>0) then qua:=1;
   if (x<0) and (y>0) then qua:=2;
    if (x<0) and (y<0) then qua:=3;
     if (x>0) and (y<0) then qua:=4;
  end;

  function dist(x,y:real):real;
 begin
   dist:=sqrt(sqr(x)+sqr(y));
 end;

begin
 read(xa,ya,xb,yb);
 writeln('Point A in ',qua(xa,ya),' quarter');
 writeln('Point B in ',qua(xb,yb),' quarter');
 writeln('The distance from the origin to the point A=',dist(xa,ya));
end.

Пример ввода:
2.75
-7.25
3
4
Пример вывода:
Point A in 4 quarter
Point B in 1 quarter
The distance from the origin to the point A=7.75403120963541
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота