miniahmetovtimu
22.10.2021 17:09

Написать программу нахождения суммы ряда от 1 до N: S=1+2+3+ …+N

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hzhwhsbsh
18.01.2023 18:42
Var
   A,k,S,M:integer;
   P:real;
Begin
Write('Введите натуральное число: ');ReadLn(A);
k:=0;
S:=0;
P:=1;
While A>0 do
   Begin
   M:=A mod 10;
   if M = 3 then k:=k+1
   else
      Begin
      if M > 5 then S:=S+M;
      if M > 7 then P:=P*M;
      End;
   A:=A div 10;
   End;
WriteLn('k = ',k);
WriteLn('S = ',S);
WriteLn('P = ',P);
End.

Var
   A:integer;
   Max,Min,M:byte;
Begin
Write('Введите натуральное число: ');ReadLn(A);
Max:=0;
Min:=10;
While A>0 do
   Begin
   M:=A mod 10;
   if M<Min then Min:=M;
   if M>Max then Max:=M;
   A:=A div 10;
   End;
WriteLn('Min = ',Min);
WriteLn('Max = ',Max);
End.
0,0(0 оценок)
Ответ:
ппчуп
19.09.2020 09:03
Вот тебе дано "ГО" , к нему приписываешь обратный порядок букв ГО,значит "ОГ".
Уже получается ГООГ. После этого приписываешь ко всему этому букву,стоящую после О в алфавите( т.к буква "О" последняя буква "ГО"). После О в алфавите идет П,поэтому получается в итоге
ГО+ОГ+П= ГООГП.
Теперь, нужно повторить этот алгоритм второй раз,только уже с набором букв, который получился после первого раза выполнения алгоритма,т.е с ГООГП.
Начнем.
ГООГП записываем наоборот => ПГООГ. 
Получаем
ГООГП + ПГООГ + Р = ГООГППГООГР
Готовый ответ: ГООГППГООГР
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота