Керис
23.03.2021 15:58

Напишите программу: 1. Подсчитать количество символов во фразе ФИО.
2.По вводимым словам, (два - три слова) печатается
фраза.
Например
Введите первое слово (сам)
Введите второе слово (ход)
На экране:
самоход
3. Вводится имя и ответ на вопрос. На экран выводится
предложение (если да, то одно, иначе – другое)
Например:
Как вас зовут? (Ирина)
Вы любите гулять? (Да) (Нет)
Если да - на экране:
Ирина. Давай прогуляемся в Летнем саду.
Иначе - на экране:
Ирина. Давай сходим в кино.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
TTpopoK
28.03.2020 07:58
Var a, b, c, rez: real;
begin
write('Введите число А: ');
readln(a);
write('Введите число B: ');
readln(b);
write('Введите число C: ');
readln(c);
if (a >= 0) and (b >= 0) and (c >= 0) then rez := a + b + c;
if (a >= 0) and (b >= 0) then rez := a + b;
if (a >= 0) and (c >= 0) then rez := a + c;
if (b >= 0) and (c >= 0) then rez := b + c;
if (a <= 0) and (b <= 0) then rez := c;
if (b <= 0) and (c <= 0) then rez := a;
if (a <= 0) and (c <= 0) then rez := b;
if (a <= 0) and (b <= 0) and (c <= 0) then rez := 0;
writeln(rez);
end.

Громоздко, но, думаю, покатит
0,0(0 оценок)
Ответ:
archik4
22.11.2021 04:55
Program v1;
var a,b,c: real;
begin
readln (a,b,c);
If c > a+b then writeln ( 'Такого треугольника не существует');
If a > c+b then writeln ( 'Такого треугольника не существует');
If b> a+c then writeln ( 'Такого треугольника не существует');
If a=b and a=c  then writeln ('Этот треугольник равносторонний');
If a=b or a=c or b=c then writeln ('Этот треугольник равнобедренный');
If a = scrt ( b*b + c*c) then writeln ('Этот треугольник прямоугольный');
If b = scrt (a*a + c*c) then writeln ('Этот треугольник прямоугольный');
If c = scrt (a*a + b*b) then writeln ('Этот треугольник прямоугольный');
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота