VolkovaI
04.04.2023 07:12

составить программу в паскале!! Заполнить массив числами от 1 до 30. Вывести на экран имена чётных элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Nikita43242
09.02.2023 06:58

Февральская революция 1917 года в России (в советской историографии — Февральская буржуазно-демократическая революция[2][3] или Февральский переворот[4], на Западе также часто используется название Мартовская революция (англ. March Revolution, в соответствии с календарём нового стиля) — массовые антиправительственные выступления петроградских рабочих и солдат петроградского гарнизона, приведшие к свержению российской монархии и созданию Временного правительства, сосредоточившего в своих руках всю законодательную и исполнительную власть в России. Революционные события охватили период конца февраля — начала марта 1917 года (по юлианскому календарю, действовавшему в то время в России).

0,0(0 оценок)
Ответ:
bon1101
25.01.2023 12:39
#include <vector>
#include <algorithm> 
using namespace std;
 int main() {
    string s; 
   vector<char> vowels = {'a','e','i','o','u','y'};
    cin >> s; 
  int count_letters = 0; //сколько букв одной гласности подряд 
  int count = 0; // сколько букв добавить 
   int state = -1; //для гласности 
   int c = state; // для запоминания 
   for(int i = 0 ;i < s.length(); i++, c = state) {
        if(find(vowels.begin(),vowels.end(),s[i])!= vowels.end()) 
           state = 0;
        else state = 1; 
       if(c==state) count_letters++; 
       if(count_letters == 3) { 
           count_letters = 1; //так как одна буква остается справа от разделяющей
            count++; 
       } 
   } 
  cout << count;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота