RickeyF2228
29.05.2023 09:57

1.
исполнения
Программирование на языке Pascal
Вариант 1
Задание Определите значение
переменной а после
данного алгоритма:
а:= 36
b:= а12
b:= b+a/4
а:=a /ь* 3
В ответе укажите одно число значение переменной а.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
den222276
12.05.2023 11:37
Двоеточие - это часть команды (оператора), который называется оператор присваивания. В данном контексте всегда используется два символа ":=". Команда присваивания y:=y-x означает, что берутся текущие значения переменных x и y, находится их разность, после чего результат записывается (говорят - "присваивается") переменной y. Например, если значение y было задано y:=20; а x:=1; то новое значение переменной y будет равно 20-1=19.
В команде x:=x*2 все аналогично. Берется текущее (установленное ранее) значение переменной x, умножается на 2, а результат этого умножения становится новым значением переменой x. Старое значение при этом безвозвратно теряется.
0,0(0 оценок)
Ответ:
taxirkuliev
15.02.2020 18:05
1)var ar:array of integer;
max,min,s,i,n,maxi,mini:integer;
begin;
randomize;
max:=-1;
min:=101;
readln(n);
setlength(ar,n+1);
writeln('Array:');
for i:=1 to n do
 begin;
  ar[i]:=random(100);
  write(ar[i]:4);
  if max<ar[i] then
   begin;
    max:=ar[i];
    maxi:=i;
   end;
  if min>ar[i] then
   begin;
    min:=ar[i];
    mini:=i;
   end;
  s:=s+ar[i];
 end;
ar[maxi]:=s;
ar[mini]:=s;
writeln;
writeln('Final array:');
for i:=1 to n do
write(ar[i]:4);
end.
2)var ar:array of integer;
k,h,i,s:integer;
f:real;
begin;
randomize;
readln(h);
setlength(ar,h+1);
writeln('Array:');
for i:=1 to h do
 begin;
  ar[i]:=random(100)-50;
  write(ar[i]:4);
  if (ar[i]>0) and (ar[i] mod 2=0) then
   begin;
    inc(k);
    s:=s+ar[i];
   end;
 end;
f:=s/k;
writeln;
writeln('Result:',f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота