Вопрос 1 Напишите программу на языке Python, которая получает
с клавиатуры натуральное число и определяет
количество цифр в этом числе,
Введите ответ в произвольной форме:
,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Angilass
18.04.2021 22:50

Відповідь:

N=int(input())

c=0

while N>0:

   N=N//10

   c=c+1

print(c)

Пояснення:

0,0(0 оценок)
Ответ:
vasta5555555
18.04.2021 22:50

i=int(input())

if i<0:

   print(len(str(i))-1)

else:

   print(len(str(i)))

Объяснение:

проверяем положительное ли число, если нет, то из длины символов вычитаем 1 (т.к. у нас "-" считается за символ), иначе выводим просто длину

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота