tukacheva88
02.06.2020 08:02

Решить на паскале: 1) Написать программу для ввода n пар натуральных чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений. На экран вывести список выбранных значений и сумму. Программу написать с использованием функции.

2) Написать программу подсчета количества четных и нечетных цифр 10 значного натурального числа. Программу написать с использованием процедуры, принимающей и возвращающей значения.

3) Написать программу для определения, является ли треугольник прямоугольным по трем введенным значениям длин его сторон. Программу написать с использованием процедуры без явного ввода значений и вывода (возврата) результата из процедуры .

4) Написать программу для ввода n пар чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений, при том так, чтобы четность суммы совпадала с четностью большинства выбранных чисел. (Если четность не совпадет, то выбрать число другой четности из пары с минимальной разностью значений). На экран вывести количество четных и нечетных чисел и максимальную сумму.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
petrovadasha200Fhcd
14.02.2020 07:11

/* c++ */

#include <iostream>

using namespace std;

int main()

{

   int A, B;

   cout << "Enter the numbers A and B" << endl;

   cout << "A: ";

   cin >> A;

   cout << "B: ";

   cin >> B;

   while (A > 100)

   {

       cout << "The numbers more than 100" << endl;

       cout << "Enter again" << endl;

       cout << "A: ";

       cin >> A;

       cout << "B: ";

       cin>> B;

   }

   if (A == B)

       cout << "ровно" << endl;

   else if (A > B)

       cout << "больше" << endl;

   else

       cout << "меньше" << endl;

   return 0;

}

0,0(0 оценок)
Ответ:
Няша177777777777
19.11.2022 04:01

1)

var a,b:longint;

begin

readln(a,b);

writeln(a+b);

end.

2)

var x:longint;

begin

readln(x);

if(x>0) then writeln(x-6) else if(x=0) then writeln(32*x-7) else if(x<0) then writeln(5*x-2);

end.

3) В третьей условие не совсем понял, если что, дополни, отредактирую код. Какие значения принимают элементы (по какому принципу заполняется массив)? Написал для массива с элементами от 1 до 50.

var a:array[1..50] of integer;

var i:integer;

begin

for i:=1 to 50 do a[i]:=i;

for i:=1 to 50 do writeln(a[i]);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота