Elli34
22.08.2021 10:27

Напишите программу, используя три вида цикла(цикл с параметром, цикл с предусловием и цикл с постусловием) 18 задание


Напишите программу, используя три вида цикла(цикл с параметром, цикл с предусловием и цикл с постусл

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
astrafikal
17.03.2020 19:47

Информация о состоянии каждого пикселя хранится в закодированном виде в памяти компьютера. Код может быть однобитовым, двухбитовым и т. д.

Код пикселя — это информация о цвете пикселя.   

Для получения черно-белого изображения (без полутонов) пиксель может находиться в одном из двух состояний: светится — не светится (белый — черный). Тогда для его кодирования достаточно одного бита памяти:

1 — белый, 
0 — черный.

Пиксель на цветном дисплее может иметь различную окраску. Поэтому одного бита на пиксель недостаточно.

Для кодирования четырехцветного изображения требуется двухбитовый код, поскольку с двух битов можно выразить 4 различных значения (отобразить 4 различных состояния). Может использоваться, например такой вариант кодирования цветов:

00 — черный,      10 — зеленый,
01 — красный,    11 — коричневый.

Из трех базовых цветов — зеленого, красного, синего — можно получить восемь комбинаций трехбитового кода:
---       черный,            к --          красный,
-- с      синий,              к - с        розовый,
- з -     зеленый,          к з -        коричневый,
- з с     голубой,           к з с       белый.

В этом коде каждый базовый цвет обозначается его первой буквой (к — красный, с — синий, з — зеленый). Черточка означает отсутствие цвета.

Следовательно, для кодирования восьмицветного изображения требуются 3 бита памяти на один видеопиксель. Если наличие базового цвета обозначить единицей, а отсутствие — нулем, то получается таблица кодировки восьмицветной палитры (табл. 4.1).


Из сказанного, казалось бы, следует вывод: с трех базовых цветов нельзя получить палитру, содержащую больше восьми цветов. Однако на экранах современных компьютеров получают цветные изображения, составленные из сотен, тысяч и даже миллионов различных красок и оттенков. Как это достигается?

Если иметь возможность управлять интенсивностью (яркостью) свечения базовых цветов, то количество различных вариантов их сочетаний, дающих разные краски и оттенки, увеличивается.

Шестнадцатицветная палитра получается при использовании четырехразрядной кодировки пикселя; к трем битам базовых цветов добавляется один бит интенсивности. Этот бит управляет яркостью всех трех цветов одновременно (интенсивностью трех электронных пучков) (табл. 4.2).


Большее количество цветов получается при раздельном управлении интенсивностью базовых цветов. Причем интенсивность может иметь более двух уровней, если для кодирования интенсивности каждого из базовых цветов выделять больше одного бита.

Из сказанного можно вывести правило:

Количество различных цветов К и количество битов для их кодирования b связаны между собой формулой: К = 2b.   

21 = 2, 22= 4, 23 = 8, 24 = 16 и т. д. Для получения цветовой гаммы из 256 цветов требуется 8 битов = 1 байт на каждый пиксель, так как 28 = 256.


Объем видеопамяти

Объем необходимой видеопамяти определяется размером графической сетки дисплея и количеством цветов. Минимальный объем видеопамяти должен быть таким, чтобы в него помещался один кадр (одна страница) изображения. Например, для сетки 640 х 480 и черно-белого изображения минимальный объем видеопамяти должен быть таким:

640 · 480 · 1 бит = 307 200 бит = 38 400 байт.

Это составляет 37,5 Кбайт.

Для четырехцветной гаммы и той же графической сетки видеопамять должна быть в два раза больше — 75 Кбайт; для восьмицветной — 112,5 Кбайт.

На современных высококачественных дисплеях используется палитра более чем из 16 миллионов цветов. Требуемый размер видеопамяти в этом случае — несколько мегабайтов.


Коротко о главном

Информация в видеопамяти — это двоичные коды, обозначающие цвета пикселей на экране.

Для кодирования двух цветов достаточно 1 бита на пиксель; четырех цветов — 2 битов; восьми цветов — 3 битов; шестнадцати цветов — 4 битов и т. д. Количество цветов К и размер кода в битах b связаны формулой: К — 2b.

Из трех базовых цветов можно получить 8 различных цветов, Большее число цветов получается путем управления интенсивностью базовых цветов.

Минимально необходимый объем видеопамяти зависит от размера сетки пикселей и от количества цветов. Обычно в видеопамяти помещается несколько страниц (кадров) изображения одновременно.

0,0(0 оценок)
Ответ:
Semen200000000
01.02.2023 10:16
// PascalABC.NET 3.0, сборка 1088
const
  n=9;
  m=7;
var
  a:array[1..n,1..m] of integer;
  b:array[1..n] of boolean;
  i,j,k:integer;
begin
  Randomize;
  Writeln('*** Исходный массив ***');
  for i:=1 to n do begin
    k:=0;
    for j:=1 to m do begin
      a[i,j]:=Random(225)-112;
      Write(a[i,j]:5);
      if a[i,j]<0 Then Inc(k)
      end;
    Writeln;
    b[i]:=k>3
  end;
  Writeln('*** Строки, содержащие больше 3 отрицательных элементов ***');
  for i:=1 to n do
    if b[i] then Write(i,' ');
  Writeln
end.

Тестовое решение:
*** Исходный массив ***
   89  -71   36  -25  -19   60  -28
  -60  -35   20  112  -69   29   74
    4  -23   -7  -15  107   64   -4
  -82   91  102  -90   81   32  -64
   41  -44   21   74   77  -77 -100
  -38  -36  100    5  -42   54   46
  -52   27  -86  -77   90   30   -2
  -76  -14  -58   11   67  -91   59
  -50   47  -47   12  -84  -76   11
*** Строки, содержащие больше 3 отрицательных элементов ***
1 3 7 8 9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота