bokkvika2908
25.12.2020 15:53

Нарисовать блок-схему и написать программу для следующей задачи. Петр и Аня сдавали норматив по прыжкам в длину. Требуется определить, кто из ребят показал лучший рез

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sleep13
16.09.2021 23:03

Еще в глубокой древности некоторые военачальники, следуя обычаю, не позволяли своим подчиненным казнить пленных, приказывали щадить женщин и детей, запрещали отравлять колодцы. Эти обычаи со временем оформились в нормы обычного права, которыми руководствовались противоборствующие стороны. В ряде случаев воюющие заключали письменные соглашения о соблюдении правил гуманного обращения с противником. Однако вплоть до второй половины XIX века такие соглашения не носили всеобщего характера и, как правило, действовали лишь во время одного сражения или одной войны.

Объяснение:

ВОЗМОЖНО ЭТО НЕ ПРАВИЛЬНО

0,0(0 оценок)
Ответ:
ROSTMIX
07.02.2020 22:00

USES CRT;

VAR m1,m2,n,n1,n2,n3,n4,n5,n6,s1,s2:LongInt;

BEGIN

ClrScr;

     ReadLn(n);

  m1:=n;

   n1:=m1 div 100;

   n2:=m1 mod 10;

   n3:=(m1-n1*100-n2) div 10;

 if n1=n2 then if n1=n3 then writeln('vse =');

 if n1=n2 then writeln('1 i 3 =');

 if n2=n3 then writeln('2 i 3 =');

 if n1=n3 then writeln('1 i 2 =')

 else writeln('<>');

 END.

Проверяйте, что непонятно - спрашивайте.

Можно чуть поправить вывод, чтобы когда vse =, не вылезали 1 i 3, 1 i 2, 2 i 3.

Да и вообще writeln'ов можно наставить и переменные назвать покрасивше. но это уж вы сами, думаю, справитесь. В VAR у меня тоже есть лишние переменные, переделывал старый свой код наспех =)

Всего хорошего.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота