123451526
10.07.2020 09:49

На С++ Седловые точки В двумерном массиве размерностью n×m, все элементы которого различны, требуется найти такие элементы, которые одновременно являются минимальными в своей строке и максимальными в своем столбце.

Входные данные

В первой строке входных данных находятся натуральные числа n,m≤100. В следующих n строках входных данных расположены по m натуральных чисел, не превосходящих 10000.

Выходные данные

Выведите пары индексов искомых элементов, каждую в отдельной строке. Нумерация строк и столбцов начинается с единицы. Если искомых элементов нет, то выведите 0.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Фариза04
18.05.2022 05:14

В город М напрямую можно попасть только из города Н (в который напрямую можно попасть только из города Ж), и из города Ж. Значит, для любого пути в Ж из А есть два варианта, как проехать в М.

В город Ж можно попасть напрямую из городов В, Г, и Д. В город В из города А можно попасть тремя путями: АБВ, АГВ и АБГВ, в город Г - двумя: АГ и АБГ, в город Е - тремя: АГЕ, АДЕ и АБГЕ.

Итого: Из города А в город Ж есть 3+2+3=8 путей, из Ж в М - 2 пути. Для каждого пути из А в Ж есть оба варианта пути из Ж в М, поэтому умножаем: 8×2=16 путей.

ответ: 16 путей

Буду очень благодарен, если Вы отметите мой ответ как лучший!

0,0(0 оценок)
Ответ:
diana125sirena62rus
03.02.2020 07:47
Delphivar  a1, a2: array of integer;  n, c, i: integer; procedure PrintDescending(a: array of integer); var i, j, max: integer; begin  for i := 0 to Length(a) - 1 do  begin    for j := 0 to Length(a) - 1 do      if a[j] > a[max] then max := j;    Write(a[max], ' ');    a[max] := -10001;  end; end; begin  //Запрашиваем ввод длины массива:  Write('Введите длину массива: ');  Read(n);    //Устанавливаем длину массивов:  SetLength(a1, n);  SetLength(a2, n);    //Заполняем первый массив случайными числами:  for i := 0 to n - 1 do    a1[i] := Random(201) - 100;    //Заполняем второй массив только нечётными элементами первого:  for i := 0 to n - 1 do    if Abs(a1[i]) mod 2 = 1 then      begin      a2[c] := a1[i];      c := c + 1;    end;    //Урезаем второй массив:  SetLength(a2, c);    //Выводим первый массив:  for i := 0 to n - 1 do    Write(a1[i], ' ');  Writeln;    //Выводим второй массив в порядке убывания:  if c = 0 then Write('Нечётных элементов нет.')  else PrintDescending(a2); end.

Пример работы:


Дан одномерный массив целого типа. Получить другой массив, состоящий только из нечетных чисел исходн
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота