zzzaharr
05.07.2020 18:16

Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100). нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условием

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PowerSell
19.06.2020 09:12
1)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
for a:=1 to 99 do begin
if a mod b = 0 then
sum:=sum+a;
end;
writeln(sum);
end.

2)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
repeat 
if a mod b = 0 then
sum:=sum+a;
inc(a);
until a=100
writeln(sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота