qqwweerrqq
02.02.2022 10:47

CРОЧНО НА С++ На вход программе подаются два целых числа m и n, по модулю не превосходящие 10^6. Если m≥n, то требуется вывести 1, в противном случае — любое другое число.

Условный оператор, операторы сравнения, циклы и функции min, max, abs использовать нельзя!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
AliceKrauch
12.05.2021 09:38

#include <iostream>

int main()

{

   int m, n;

   std::cin>>m>>n;

   int target = m - n;  

   std::cout << -1 * (target >> (8 * sizeof(target) - 1))+1;  

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота