KarenXacul80
15.05.2020 20:14

Python Написать программу «Династия», в которой хранятся сведения о родственных связях сын-отец (не менее 10 пар значений).
Предполагается, что у каждого отца только один сын-наследник
(например, представители царской династии). Программа должна
уметь определять, кто отец заданного представителя династии и
кто его дед (предусмотреть обработку ошибочного ввода и
отсутствия деда). Python

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
djiner
24.04.2021 20:31

var a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) and (b>c) then writeln('c=',c,'b=',b,'a=',a) else
if (b>a) and (b>c) and (a>c) then writeln('c=',c,'a=',a,'b=',b) else
if (c>a) and (c>b) and (b>a) then writeln('a=',a,'b=',b,'c=',c) else
if (a>b) and (a>c) and (c>b) then writeln('b=',b,'c=',c,'a=',a) else
if (b>a) and (b>c) and (c>a) then writeln('a=',a,'c=',c,'b=',b) else
if (c>a) and (c>b) and (a>b) then writeln('b=',b,'a=',a,'c=',c) else
readln;
end.

0,0(0 оценок)
Ответ:
Яхшибой
24.04.2021 20:31

var a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) and (b>c) then writeln('c=',c,'b=',b,'a=',a) else
if (b>a) and (b>c) and (a>c) then writeln('c=',c,'a=',a,'b=',b) else
if (c>a) and (c>b) and (b>a) then writeln('a=',a,'b=',b,'c=',c) else
if (a>b) and (a>c) and (c>b) then writeln('b=',b,'c=',c,'a=',a) else
if (b>a) and (b>c) and (c>a) then writeln('a=',a,'c=',c,'b=',b) else
if (c>a) and (c>b) and (a>b) then writeln('b=',b,'a=',a,'c=',c) else
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота