ketkovalchuk
20.04.2021 05:10

Написать программу которая вычисляет разность и произведение четырёх вещественных чисел, которые вводятся из клавиатуры. Нарисовать блок схему и данные ввода - вывода

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ludmila28041985
05.04.2023 16:14
Компьютер библиотекарь обычному человеку, который пришел в библиотеку, найти нужную ему книгу из списка книг всей большой библиотеки. Человек просто вбивает название нужной ему книги и компьютер быстро находит данную книгу и говорит, где она находиться. Так же и с работников самой библиотеки, если они не могут найти книгу для своего клиента, то они смотрят, есть ли данная книга в библиотеке, и где она находиться. Это намного упрощает работу библиотекаря! Ведь не надо бегать по всей библиотеке и запоминать, где находиться книга и есть ли она вообще!
0,0(0 оценок)
Ответ:
olga638
05.04.2023 16:14
{$R+,S+,Q+} uses  SysUtils; const R=1000;type Mas= array [0..R] of integer;var  a: Mas;  en,n: integer;  x,y,z,q,w: char;function push(n: integer): string;begin  a[en]:=n;  en:=en+1;  push:='ok';end;function pop(): integer;begin  en:=en-1;  pop:=a[en];  a[en]:=0;end;function back(): integer;begin  back:=a[en-1];end;function size(): integer;begin  size:=en;end;function clear(): string;begin  en:=0;  clear:='ok';end;function exit(): string;begin  exit:='bye';end;begin  en:=0;  repeat    read(x);    if x='p' then    begin      read(y);      if y='u' then      begin        read(z,q,w);        readln(n);        writeln(push(n))      end else begin        readln(z);        writeln(pop());      end;    end;    if x='b' then    begin      readln(y,z,q);      writeln(back());    end;    if x='s' then begin      readln(y,z,q);      writeln(size());    end;    if x='c' then begin      readln(y,z,q,w);      writeln(clear());    end;    if x='e' then begin      readln(y,z,q);      writeln(exit());    end;  until x='e';end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота