Рыпвапрвгпвшпр
10.06.2022 07:36

Записать что дано, найти, составить блок-схему и программу в паскале 1. Даны два числа. Возвести в квадрат те из них, значения которых
неотрицательны, и увеличить на 2,5 те, которые положительны.
2. Подсчитать количество отрицательных среди чисел a, b, c.
3. Рис расфасован в два пакета. Масса первого — Т кг, второго п
кг. Составить программу, определяющую:
а) какой пакет тяжелее — первый или второй;
6) массу более тяжелого пакета. ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastafil30
28.07.2022 10:39
Var x, temp, p, a, original: integer;
found: boolean;
begin
found:=false; //переменная примет значение "истина" тогда, когда число А будет найдено в цифрах первого числа
writeln('Введите натуральное число");
Readln(original);
Writeln('Введите число A');
Readln(a);
x:=original;
p:=1; //будет хранить произведение цифр числа(если приравнять нулю, то произведение всегда будет равно нулю)
while x>0 do            //пока X болльше нуля
  begin
    temp:=x mod 10;     //заносим последнюю цифру числа X в переменную temp
    if temp=a then found:=true; //если цифра числа равна A, то помечаем, что нашли ее
    p:=p*temp;          //домножаем произведение на цифру
    x:=x div 10;        //отбрасываем последнюю цифру числа через целочисленное деление
  end;
Writeln('Произведение цифр числа ' + original + ' равно ' + p);
if found then writeln('Цифра' + a + ' есть в исходном числе ' + original)
else writeln('Цифра ' + a + ' отсутствует в оригинальном числе ' + original)
end;
0,0(0 оценок)
Ответ:
оооопп
06.05.2022 20:19

I. Ламповые машины. Операционные системы отсутствовали.

Первые компьютеры 50-х годов - большие, громоздкие и дорогие - предназначались для очень небольшого числа избранных пользователей. Такие компьютеры не были предназначены для интерактивной работы пользователя, а использовались в режиме пакетной обработки.

II. Компьютеры на основе транзисторов. Пакетные операционные системы.

Компьютеры второго поколения стали более надежными, теперь они смогли непрерывно работать настолько долго, чтобы на них можно было возложить выполнение действительно практически важных задач.

III. Компьютеры на основе интегральных микросхем. Первые многозадачные ОС.

В это время в технической базе произошел переход от отдельных полупроводниковых элементов типа транзисторов к интегральным микросхемам. Вычислительная техника становится более надежной и дешевой. Растет сложность и количество задач, решаемых компьютерами. Повышается производительность процессоров.

IV. Персональные компьютеры. Классические, сетевые и распределенные системы.

В эти годы произошло резкое возрастание степени интеграции и удешевление микросхем. Компьютер, не отличающийся по архитектуре от PDP-11, по цене и простоте эксплуатации стал доступен отдельному человеку. Наступила эра персональных компьютеров.

Надеюсь Не забудь поставить " ").

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота