Piragovicch
04.11.2021 20:23

Паскаль! Написать программу,которая выясняет самый холодный день за неделю (холодный день это ниже -10 градусов C). Температурные измерения показать в программе. Использовать array (массивы ) Много даю

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Carlso3000
11.02.2023 09:50

Первое задание:

1) 3

2) 6

3) 5

Второе задание:

1) 1

2) 3

Третие:

//Язык программирования java

package com.niksonbinsk;

import java.util.ArrayList;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       int space_left = 0;

       int count = 0;

       Scanner s = new Scanner(System.in);

       ArrayList<Integer> str = new ArrayList<>();

       while(space_left != 30){

           System.out.println("Enter next num:");

           str.add(s.nextInt());

           space_left++;

       }

       for(int i =0;i<30;i++){

           if(str.get(i) % 2 == 0){

               count++;

           }

       }

       System.out.println(count);

   }

}

Объяснение:

0,0(0 оценок)
Ответ:
владимир203
21.01.2020 07:13
1.var
   max,min,i:integer;
   b:real;
   a:array[1..9]of integer;
begin
for i:=1 to 9 do
  begin
  while (a[i]<1) or (a[i]>6) do
    begin
    write(i,' оценка: ');
    readln(a[i]);
    end;
  if i=1 then
    begin
    max:=a[1];
    min:=a[1];
    end;
  if a[i]>max then max:=a[i];
  if a[i]<min then min:=a[i];
  b:=b+a[i];
  end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end. 

2. #include <stdafx.h> 
#include <stdio.h> 
#include <math.h> 
#include <stdlib.h> //for rand; 
int main()
 { 
int i, n,M[1]; 
 printf("Vvedit N:");
  scanf("%d",&n); 
for (i = 0; i < n; i++) 
 { 
  M[i] = rand()%10; 
    }
for (i = 0; i < n; i++) 
 { 
     printf("Array[%d] = %d\n", i, M[i]);
  } 
          scanf("%d"); 
return 0; 
}

3. var

a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадковых чисел');
min:=a[0];
for i:=1 to 9 do
if a[i]<min then min:=a[i];
writeln(min, ' - минимальне число.');

end. 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота