petrovskayaanna
11.09.2022 07:10

Написать программу нахождения суммы элементов массива. Размер массива задать самостоятельно.Программа должна вывести элементы массива и сумму этих элементов массива программа: Pascal ABC.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1Nikanikanika1
22.01.2020 17:05
Var
  i,n,k:integer;
  p:longint;
  f,ff:boolean;
begin
  Write('Введите количество чисел -> '); Readln(n);
  Writeln('Тeперь вводите сами числа');
  p:=1; f:=false; ff:=false;
  for i:=1 to n do
  begin
    Read(k);
    f:=((k<0) and ((k mod 2)<>0));
    ff:=(ff or f);
    if f then p:=p*k
  end;
  if ff then Writeln('Произведение нечетных отрицательных чисел: ',p)
  else Writeln('Не было введено ни одного отрицательного нечетного числа')
end.

Тестовое решение:
Введите количество чисел -> 10
Тeперь вводите сами числа
5 -7 16 0 -3 4 -6 2 1 8
Произведение нечетных отрицательных чисел: 21
0,0(0 оценок)
Ответ:
ванёк10062005
07.04.2023 01:34
Var
  a,b,c,d,x,y:real;
begin
  Write('Введите размеры сторон сундука -> '); Readln(a,b,c);
  Write('Введите диаметр иллюминатора -> '); Readln(d);
  if a<b then begin
    x:=a;
    if b<c then y:=b else y:=c
  end
  else begin
    x:=b;
    if a<c then y:=a else y:=c
  end;
  if (sqr(x)+sqr(y)<sqr(d)) then Writeln('Сундук можно вытащить')
  else Writeln('Сундук нельзя вытащить')
end.

Тестовое решение:
Введите размеры сторон сундука -> 3 5 3.99
Введите диаметр иллюминатора -> 5
Сундук можно вытащить

**********************
Условие попадания точки A(x,y) внутрь треугольника описывается как
\begin {cases} x\ge 0 \\ y\ge 0 \\ y\le 5-x \end {cases} \Rightarrow \ (x\ge0) \land (y\ge0) \land (y\le 5-x)

var
  x,y:real;
begin
  Write('Введите координаты x и y точки -> '); Readln(x,y);
  if (x>=0) and (y>=0) and (y<=5-x) then Writeln('Да')
  else Writeln('Нет')
end.

Тестовое решение:
Введите координаты x и y точки -> 3 2.5
Нет

Введите координаты x и y точки -> 2.1 2.8
Да
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота