GRISHINANASTYA
28.02.2020 16:05

Напишите программу, используя repeat или while, которая вычислит на какой день число вылупившихся из яйца утят станет больше 120, если известно что в инкубаторе в 1-ый день вылупилось 5 утят, а в каждый последующий день вылупливалось на 10 утят больше, чем в предыдущий. Паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KINGMe
10.02.2021 03:05

Объяснение:

1) int x = 5;

x++;    до х додаєтся 1

х=6

41) int x = 5;

x--;   від х віднімається 1

х=4

42) int x = 5;

x += 3; до х додаєтся 3

х=8

43) int x = 5;

x -= 3; від х віднімається 3

х=2

44) int x = 5;

x *= 3; х перемножають на 3

х=15

45) int x = 6;

x /= 3;

х=2

46) int x = 5; int y;

y = x % 2;

y=1

47) int x = 5; int y;

y = abs( x ); модуль числа (його позитивне значення)

у=5

48) int x = -5; int y;

y = abs( x ); модуль числа (його позитивне значення)

у=5

49) float x = 4; float y;

y = sqrt( x );   sqrt( x ); це √х

у=2

50) float x = 3; float y;

y = pow( x, 2 ); домножає х на себе 2 рази тобто возводиь у другу ступінь

y = х*х

y = 3*3

y = 9

51)  float f = 32.51;

printf("%2.1f", f);  не впевнений

32.5

52) int x = 4; int y;

if(x 4) y = x; тут якась помилка якщо в дужках повинно бути (x==4) то умова була такою якщо х дорівнює 4 то  y = x, тобто у теж дорівнює 4 інакше y дорівнює х помножений на 2

else y = 2*x;

y = 4

0,0(0 оценок)
Ответ:
Akhram
13.04.2021 14:40

Короче. Вот код.

def matrix_gen(gen, n, m):    Matrix = [];    for i in range(n):        a = [];        for j  in range(m):            a.append(gen[j]);        Matrix.append(a);    return Matrix;

Объяснение

Сначало ты инициализируешь функицю с названием "matrix_gen", которая принимает 3 параметра, 'gen' -- это генератор которые ты будешь использовать. 'n' & 'm' это размер матрицы.

Второй строчкой ты инициалихируешь пустой массив, которые похже заполнишь. Третей строчкой ты в for цикле обходишь все строки матрицы, они же подмассивы массива  Matrix, просто 'a'. Делаем мы это 'n' раз.

Четвётрой строчкой ты инициализируешь массив(ы, мы в цикле) 'a', и следующей строчкой заполняешь уже его. Так же в for цикле. Всего в нём будет 'm' элементов.

Надеюсь решение правильное. Честно говоря у тебя вопрос очень странно поставлен.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота