gagammil
02.06.2020 16:31

Написать программу, которая решает следующую задачу. Проверить, принадлежит ли точка третьей координатной четверти.
Выдержка из математики. Точка принадлежит третьей координатной четверти, если ее абсцисса и
ордината меньше нуля.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Незнайка0091
12.10.2020 17:22
Программа считывает строку с клавиатуры, разбивает ее на числа (их может быть больше двух) и суммирует все найденные числа. Программа работает только с суммой, для выполнения других действий, необходима доработка.

Код:
procedure calculateSum(str : string);var s0 : string;    number, sum : real;begin  sum := 0;  foreach s0 in Regex.Split(str, '\++') do  begin    number := StrToFloat(s0);    if (number > 0) then    begin      sum := sum + number;    end;  end;  writeln(str + '=' + sum);end;
var s : string;begin  write('Введите пример: ');  readln(s);
  calculateSum(s);  end.
Склавиатуры вводится строка, содержащая пример на суммирование 2=х чисел. подсчитать сумму и вывести
0,0(0 оценок)
Ответ:
Elay11
22.05.2021 09:15
1. Современное решение

// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  var min:=a.Min;
  a.Transform(x->x<0?x*min:x); a.Println
end.

Пример
n= 15
-34 7 0 -48 4 42 35 14 -47 6 -29 43 46 40 -18
1632 7 0 2304 4 42 35 14 2256 6 1392 43 46 40 864

2. Популярное до сих пор в школах решение на TurboPascal 7.01 (1983г.)

uses Crt;
const
  nn=100;
var
  i,n,min:integer;
  a:array[1..nn] of integer;
begin
  ClrScr;
  Randomize;
  Write('n='); Read(n);
  min:=100;
  for i:=1 to n do begin
    a[i]:=Random(101)-50;
    Write(a[i],' ');
    if a[i]<min then min:=a[i]
    end;
  Writeln;
  for i:=1 to n do
    if a[i]<0 then a[i]:=a[i]*min;
  for i:=1 to n do
    Write(a[i],' ');
  Writeln;
  ReadKey
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота