оля1890
20.08.2022 06:31

Сделайте Написать программу:
Дан четырёхугольник с длинами сторон A,B,C,D
Написать программу вычисления периметра данного прямоугольника.
Длины сторон вводятся с клавиатуры.
Результат выводится на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LTKaty
20.09.2021 14:07

javascript:

function Вычислить(число) {  

var массив = [], м1 = [], м2 = [], с1 = 0, с2 = 0;  

for (let сч = 1; сч <= число; сч++) массив.push(сч);  

for (let сч = число - 1; сч >= 0; сч--)  

 if (с1 > с2) { м2.push(массив[сч]); с2 += массив[сч]; }  

 else { м1.push(массив[сч]); с1 += массив[сч]; }  

if (с1 != с2) return false;  

else {  

 var рез = "";  

 for (let сч = 1; сч <= число; сч++)  

  if (м1.indexOf(сч) != -1) рез += "+"; else рез += "-";  

 return рез;  

}

}

document.write(Вычислить(8) + "<br />");

document.write(Вычислить(15) + "<br />");

document.write(Вычислить(40) + "<br />");

document.write(Вычислить(99) + "<br />");


+--++--+

--++--++--++--+

+--++--++--++--++--++--++--++--++--++--+

--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--++--+

0,0(0 оценок)
Ответ:
енот252
13.09.2022 11:38
#include <iostream>
using namespace std;
int main() {
        int mat[3][3];
        int k;
        int size=0;
        int * arr=0;
        for(int i=0;i<3;i++){
                for(int j=0;j<3;j++){
                       cin>>mat[i][j];
                          if (mat[i][j]>0){
                             arr=(int*)realloc(arr,sizeof(int)*(++size));
                             arr[size-1]=mat[i][j];
                                             }
                                           }
                                    }
                  for(int i=0;i<size;i++){
                  cout<<arr[i];
                  }
               delete arr;
               cin.get();
               cin.get();
              return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота