Sn00ру
09.02.2022 00:28

Напишите программу, которая будет считывать с клавиатуры пароль и проверять соответствует ли
введенный пароль требованиям и возвращает True,
если соответствует и False, если нет. Пароль должен
содержать:

а) буквы (регистр не важен)

б) как минимум одну цифру

А также НЕ должен содержать пробелов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ksenia5051
30.04.2021 15:27

python

password  = input()

have_letter = False

have_diggit = False

have_space = False

for i in password:

 if i.isalpha():

   have_letter = True

 elif i.isdigit():

   have_diggit = True

 elif i == ' ':

   have_space = True

if have_letter and have_diggit and not have_space:

 print(True)

else:

 print(False)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота