drshev
30.04.2023 19:58

С клавиатуры вводят целые числа. Написать программу, которая рассчитывает сумму чисел больших 20; среднее арифметическое значение нечетных чисел. Количество чисел
вводят с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ргшгр
29.04.2021 11:51

на Free Pascal

Объяснение:

var

 a : integer;

 n, i, big, nc, ncount  : integer;

begin

 writeln('Введите количество чисел :');

 readln(n);

 big := 0;

 nc := 0;

 ncount := 0;

 for i := 1 to n do begin

   writeln('Введите ', i, ' число:');

   readln(a);

   if a>20 then

     big := big + a;

   if (a mod 2) <> 0 then begin

     nc := nc + a;

     inc(ncount);

   end;

  end;

 writeln('Сумма чисел > 20 = ', big);

 writeln('Среднее арифметическое ',ncount,' нечётных чисел =', nc/ncount:2:2);

end.

0,0(0 оценок)
Ответ:
danayamirnaya
29.04.2021 11:51

sum = sum_odd = k = 0

mass = [int(input('введите элемент массива: ')) for s in range(int(input('введите n: ')))]

for i in range(len(mass)):

   if mass[i] > 20:

       sum += mass[i]

   if mass[i] % 2:

       sum_odd += mass[i]

       k += 1

average = sum_odd / k

print(sum, average)

Объяснение:

на Питоне

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота