СоваИгорь
18.03.2021 13:27

3. Используя цикл «for», написать программу на языке С++ для решения следующей зада-чи: Среди всех двузначных чисел найти количество таких, у которых удвоенное произ-ведение цифр кратно 3. Например, у числа 23 удвоенное произведение цифр 2*(2*3) = 18, т.е. кратно 3, а у числа 25 удвоенное произведение цифр 2*(2*5) = 20 не кратно 3. Определите, сколько чисел удо-влетворяет задаче

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
marinasok23
28.04.2021 17:11

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int i, kol = 0;;

   for(i = 10; i < 99; i++){

       if( (2 * ((i % 10) * (i /10))) % 3 == 0){

           ++kol;

       }

   }

   cout<<"Количество чисел: "<<kol<<endl;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота