ctalin123123
26.01.2020 11:07

Использование языка ассемблера в программах на Turbo Pascal 7.0 Тема: Проектирование программы оболочки.

Задание: Написать программу наподобие FAR manager, NC, проводник, позволяющую переходить по каталогам на текущем носителе. При отображении в текущем каталоге файлы с заданным атрибутом выделить цветом, отличающимся от остальных файлов. Внутри каждого файла текущего каталога найти количество повторений слова, заданно-го преподавателем.

Требования к работе: Файлы обрабатывать как нетипизированные. Подготовить заранее не менее 5 примеров. В число примеров обязательно должны быть включены файлы, в которых слово начинается в одном блоке и заканчивается в другом. Лабораторную работу можно писать в среде Delphi или Turbo Pascal.

Состав отчета: Титульный лист; постановка задачи; текст программы; описание результатов работы с экранными копиями.

Варианты лабораторных работ. Вариант состоит из трех цифр: первая - длина искомого слова; вторая - атрибут файла; третья - цвет выделения. (10 вариант) 7-(длина слова) 2-(атрибут файла скрытый) 5-(цвет коричневый)

Лабораторная работа 4

Тема: Расчет приближенных корней уравнения.

Задание: Написать на языке С (Visual C) программу по нахождению корня уравнения на промежутке с точностью до 0,01. Вывести график функции, точки приближения на графике, количество итераций, значение корня.

Состав отчета: Титульный лист; постановка задачи; текст программы; описание результатов работы с экранными копиями.

Варианты лабораторных работ. В вариантах работ первая цифра - уравнение, вторая - промежуток; третья - метод.

(10 вариант) уравнение: 3Х^(3)-13Х^(2)-14Х+57 Промежуток: [1,3] (метод дихотомии).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Агаисмаил1
08.12.2021 13:25
Программа:
a = input("Введите текущую координату фигуры(вертикаль): ")
b = input("Введите текущую координату фигуры(горизонталь): ")
c = input("Введите координату для хода(вертикаль): ")
d = input("Введите координату для хода(горизонталь): ")
# Условие
if (a==c) and (b==c):
#Конец условия
     print("Фигура может сделать ход")
else:
     print("Фигура НЕ может сделать ход")
Условия:
а) if (a==c) and (b==c): #ладья
б) if abs(a-c) == abs(b-d): #слон
в) if abs(a-c)==1 or abs(b-d)==1: #король
г) if abs(a-c) == abs(b-d) or a == c or b == d: #ферзь
ж) if((abs(abs(a-c)-2)<0.5) and (abs(abs(b-d)-1)<0.5)
        or (abs(abs(a-c)-1)<0.5) and (abs(abs(b-d)-2.0)<0.5)): #конь
0,0(0 оценок)
Ответ:
missgur04
31.12.2022 07:31
Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота