justnastya1
25.11.2021 13:00

Сделайте на питоне,да Найдите все натуральные числа, принадлежащие отрезку [45000000;50000000], у которых ровно пять различных нечётных делителей (количество чётных делителей может быть любым) в ответе перечислите найденные числа в порядке возрастания

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kuzhbapolina20
29.05.2023 02:51
Var
a1,a2,b1,b2,c1,c2:integer;
begin
writeln('Координаты превой клетки');
writeln('введите номер столбца');
readln(a1);
writeln('введите номер строки');
readln(a2);
writeln('Координаты второй клетки');
writeln('введите номер столбца');
readln(b1);
writeln('введите номер строки');
readln(b2);
if ((a1 mod 2) <> 0) then
if ((a2 mod 2) <> 0) then c1:=0 else c1:=1;
if ((a1 mod 2) = 0) then
if ((a2 mod 2) <> 0) then c1:=1 else c1:=0;
if ((b1 mod 2) <> 0) then
if ((b2 mod 2) <> 0) then c2:=0 else c2:=1;
if ((b1 mod 2) = 0) then
if ((b2 mod 2) <> 0) then c2:=1 else c2:=0;
if c1=c2 then writeln('YES') else writeln('NO')
end.
0,0(0 оценок)
Ответ:
avernius
24.06.2021 13:28
Var
d:integer;
const
a=650;
b=1;
c=1000;
begin
write('Введите объём видеофайла в мегабайтах: ');
readln(d);
if d>a then write('Видеофайл не помещается на  носитель информации"А"!',#10) else
writeln('Памяти хватает для записи на носитель "А"! ',#10);
if d>b then write('Видеофайл не помещается на  носитель информации"B"!',#10) else
writeln('Памяти хватает для записи на носитель "B"! ',#10);
if d>c then write('Видеофайл не помещается на данный носитель информации"С"!',#10) else
writeln('Памяти хватает для записи на носитель "C"! ',#10);
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота