voloseikotatian
06.02.2020 20:56

Составьте программу, вводящую true, если высказывание является истинным, и false в противном случае: а) сумма цифр трёхзначного числа х является чётным числом;
б) треугольник со сторонами a, b, c является разносторонним.
))) СОСТАВЬТЕ ПРОГРАММУ В ПАСКАЛЕ ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ArsenhikBRO
24.04.2021 08:22

a)

var

a, sum, i : integer;

begin

readln(a);

sum:=0;

while a > 0 do begin

sum:= sum + (a mod 10);

a:= a div 10;

end;

writeln((sum mod 2) = 0);

end.

б)

var

a, b, c: integer;

res: boolean;

begin

readln(a, b, c);

res := (a <> b) and (a <> c) and (b <> c);

writeln(res);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота